Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email scrogged just after midnight

Discussion in 'E-mail Discussions' started by PCZero, Mar 28, 2017.

  1. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    552
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    Earth
    Email for all of my clients is scrogged just after midnight. Historically I have had an SSL certificate set up as shared and it worked just fine for years. It is about to expire in three weeks but I do not think that is relevant info. I use Eudora as my mail client and I (and my clients) get the error for ALL email accounts on the server

    "The server's SSL certificate was rejected for the following reason: Unknown Error"



    I have attempted to use the install certificate method to fix this but it is not working at all for me or ANY of my clients.


    By logging into webmail I discovered that cPanel force installed some sort of free SSL certificate just at the same time the errors started.

    "Your system upgrade to cPanel & WHM includes a free SSL certificate for your
    server's hostname. This email confirms that the system will soon
    automatically download and install your free SSL certificate.


    Comodo cross-signs your new certificate, which 99.9% of browsers
    trust. Your free certificate will renew automatically, less than one week
    before its expiration date, at no cost to you.


    For more information, read our Release Notes on free cPanel-signed hostname
    certificates.


    The certificate covers the following domains:

    myhostanme.mydomain.com
    www.myhostname.mydomain.com"


    What the hell is going on and how do I fix this ASAP. I already have several clients calling me demanding a fix.


    SUGGESTION: NEVER EVER force install things like this on serves. It can cause errors like what I am experiencing!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    552
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    Earth
    When using the wizard in WHM to create the ticket I get the following error.


    Error: The system failed to authorize access to the server with following error: API failure: (XID nykcbv) The temporary wheel user “get” operation failed with a “sudo” error: The system cannot create a temporary user because this server does not permit wheel users to use “sudo”.
     
  4. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    552
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    Earth
    In reading the documentation at the supplied link I see that I can disable the free cert by

    /var/cpanel/ssl/disable_service_certificate_management

    If I do this will it reverse all of the unrequested actions that cpanel performed and have my system back to the way it was?
     
  5. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    552
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    Earth
    Michael please see ticket
    8341797 - Email SSL errors occurring


    Thanks,
    David
     
  6. PCZero

    PCZero Well-Known Member

    Joined:
    Dec 13, 2003
    Messages:
    552
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    Earth
    Over 24 hours and I still have clients who cannot access mail. This is not good. I am not at all trying to lay blame for the issue, it could be something that I have set up wrong on my end at the server, but I really would like to have someone look at the ticket as soon as possible please!

    Thanks...
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, it looks like this issue relates to the Eudora email client and it's lack of support for SNI. The workaround suggested was to use the server's hostname as the mail server name in the email client configuration, or to switch to another email client that supports SNI.

    Thank you.
     
Loading...

Share This Page