The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email 'send from' info listed as main account nobody

Discussion in 'E-mail Discussions' started by Jan Klerks, Jun 22, 2006.

  1. Jan Klerks

    Jan Klerks Member

    Joined:
    Mar 30, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    When sending an email through of the accounts, the send from info in the receivers mail reads: nobody@-mainaccount-.com. Any way of setting that to the proper send from account? Thanks.
     
  2. kistler

    kistler Well-Known Member

    Joined:
    Jan 27, 2005
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    install phpsuexe, you can use easyapache to do this aswell

    also in Tweak Settings check "Prevent the user "nobody" from sending out mail to remote addresses"
     
  3. jester.ro

    jester.ro Well-Known Member
    PartnerNOC

    Joined:
    Feb 6, 2004
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest, Romania
    cPanel Access Level:
    DataCenter Provider
    that's the return path of emails sent using mail() function of php.

    You want to do this serverwide, or just for a specific account/script?

    Serverwide, only solution is phpsuexec.

    For only one scrip, you should check the syntax for the php mail() function.
    There is a fifth parameter for setting the returnpath.

    mail($to,$subject,$message,$headers,-fRETURN_PATH@server.com);

    (no space betweeen "-f" and the email address.)
     
Loading...

Share This Page