The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email sending problems - Site list is missing: mailman

Discussion in 'E-mail Discussions' started by BP Steven, Dec 1, 2005.

  1. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    This afternoon my server started having problems with sending out emails. It gives various reasons, such as Could not connect to SMTP server or Check your authentication details. This seems be to occuring across all domains. An email will get sent maybe once out every 70 attempts if you're lucky. I was checking my daily server emails and noticed one I don't normally get.

    Cron <mailman@action> /usr/bin/python -S /usr/local/cpanel/3rdparty/mailman/cron/mailpasswds

    Site list is missing: mailman


    I have cpanel set to upgrade automatically and it seems it has broken something to do with mailman. I have no idea how to fix. Anyone else know?
     
    #1 BP Steven, Dec 1, 2005
    Last edited: Dec 1, 2005
  2. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I fixed the mailman problem by running /scripts/reinstallmailman but the email problem still remains. I've tried restarting exim and cpop. I've also forced an exim upgrade. I'm using the latest STABLE build. The server works fine in every way except for sending emails. I can still receive mail without problems.
     
  3. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
  4. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
  5. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Not sure from the info given... Well .. needs to have a look at it... to see what exactly the issue...
     
  6. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    It just said this in outlook "The server responded: -ERR Sorry cannot find an owner for that domain (mydomain.com)"
     
  7. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Now I can't log into cpop3 on one account. It's behaving very strangely.
     
  8. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    can you send using webmail ?
     
  9. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I can't log into my webmail, but that's been a problem for ages now. Basically, my accounts will only send if I try a good number of times, and pop3 has totally failed on one account. It's very weird. I've checked for signs of hacking but there are none. Everything was fine this morning then it just started messing around like this. I had done nothing to the server over the past week at the very least.
     
  10. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Ahh, I think the pop3 error is being caused by me changing the hostname earlier today. So we can probably disregard it. The SMTP problem is still there though.
     
  11. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Okay, it also seems like files are disappearing as well.
     
  12. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    If you are having issues with your server for some time now and if you are unable to get it work,
    i would suggest that you hire some one or get someody whoi is willing to check it out for you. I feel one can't figure out without having a check...
     
  13. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I've fixed the pop3 account. It was a hostname problem. The domain had been removed from /etc/userdomains. The SMTP problem seems to work this way. It will occasionally let one email get sent. It seems this happens after I stop trying to send for a while. If I try to send shortly after one gets through the it keeps giving me error messages. The first few error messages seem to be different from the rest. I haven't changed anything on the server at all so I can only assume a cpanel update caused this. Has there been any changes to exim that might be causing this?
     
  14. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I haven't been having issues. Webmail has always been dodgey in my experience, even on other servers.
     
  15. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    I are using the webmail for longtime and i didn't face any issues and also on all the servers we manage. I am not sure what issues you face with the webmail. Anyway if you are prepared to live with that, then no troubles...
     
  16. BP Steven

    BP Steven Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    I've fixed it on all domains except for one by running /scripts/fixeverything. Any ideas why it didn't fix that one? I've compared file permissions and ownerships between working accounts and the one that doesn't on the etc and mail folders and them seem fine.
     
  17. sumith

    sumith Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    96
    Likes Received:
    2
    Trophy Points:
    8
    mailman

    hmm, can you reset the password of that account and try the same again?
     
Loading...

Share This Page