Email sent from my domain has "{Spam?}" tag in front of the email subject.

Operating System & Version
Linux
cPanel & WHM Version
90.0.9

KasunVinod

Registered
Sep 15, 2020
3
0
1
Sri Lanka
cPanel Access Level
Website Owner
I am using a shared hosting package to host my website. And I'm using Cloudflare as my CDN and SSL provider. I changed name servers to Cloudflare name servers in the beginning. My website works perfectly, but I'm having a few problems related to sending emails.

01. Email sent from email address created under my domain get {Spam?} tag in front of the subject line.

In the beginning, I thought all the emails sent from our domain get this tag in front of the subject line. But recently, I have noticed that internal emails ( emails sent from email addresses under our domain to another email address under our domain) get this tag. Further, if we CC an internal email address when sending a mail to a third party, those emails also get the {Spam?} tag.

02. "Not authorised to deliver mail" error when sending emails to some outside email addresses.

This is something I have noticed recently. When we are sending emails to some company email address (not Gmail, not yahoo mail), we are getting an error.

SMTP error from remote mail server after RCPT TO:<[email protected]>: 451-<IPAddress> is not yet authorized to deliver mail from\n451 <[email protected]> to <[email protected]>. Please try later.
Please help me to solve this issue. I have attached screenshots of cPanel DNS Record, Cloudflare DNS records and screenshots of all the errors.
 

Attachments

Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
I believe both of these issues are related. If you go to cPanel>>Email>>Email Routing does this display as Automatically Detect: Remote or is it set to remote? If so you need to change this to say Local
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,442
1,004
313
cPanel Access Level
Root Administrator
@roland.tamberg - since this is an older thread it might be best to create a new one where you provide some specifics on the issues you are seeing. If you are seeing your own server's messages getting marked as spam you may want to work through our checklist here to see if those steps help your situation: