The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Email shows up in bulk folders

Discussion in 'E-mail Discussions' started by yurster, Oct 25, 2005.

  1. yurster

    yurster Member

    Joined:
    Jun 13, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ok. I've searched and searched and haven't found a solution for this issue. I'm hoping someone can point me in the right direction.

    I have 2 servers. Both are configured exactly the same (from what I can tell). Both have RDNS setup correctly. If I send an email to a yahoo account from both servers...one shows up fine and the other ends up in the bulk folders.

    Here is the only difference I've found between the 2 emails. The email that works (or doesn't end up in the Bulk mail folder) contains the following headers:

    X-MyMailScannerTag-MailScanner-Information: Please contact the ISP for more information
    X-MyMailScannerTag-MailScanner: Found to be clean
    X-MyMailScannerTag-MailScanner-SpamCheck:
    X-MyMailScannerTag-MailScanner-From: me@mydomain.com

    The email that ends up in the bulk folders doesn't contain those additional headers. I've compared the MailScanner configurations side by side and can't find any difference. How can I have those headers added? I have MailScanner installed on both servers and configured exactly the same (from what I can tell). I'm not even sure that adding the headers will solve my issue...but I'm not sure where else to start.

    Thanks in advance for any insight,
     
  2. yurster

    yurster Member

    Joined:
    Jun 13, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Any suggestions?

    Sorry to be a pain...I know most of you are busy with other issues...but does anyone have any suggestions?
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No idea why yahoo would treat them differently - you'd have to check with yahoo.

    With regard to the email tagging, you should make sure that you've upgraded the MailScanner installations with our free script to the latest releases. You should always get the MailScanner header lines if you have the default MailScanner configuration setup and have set values for the header records in MailScanner.conf correctly (i.e. alphanumerics only).
     
  4. jerrek71

    jerrek71 Active Member

    Joined:
    Jul 27, 2006
    Messages:
    42
    Likes Received:
    1
    Trophy Points:
    6
    I've been advised by Hotmail that this could be the reason my IP address is repeatedly blocked by them, so I URGENTLY need to stop these headers being injected for outbound mail (they're a nonsense for outbound anyway to be honest - anyone can forge them to try to fool the remote ends spam scanning software into believing its been checked... Which is why Hotmail is objecting I suspect)

    If you can tell me how to disable these headers, and the X-Anti-Abuse headers I'd very much appreciate it!

    Cheers,
    Steve
     
  5. jerrek71

    jerrek71 Active Member

    Joined:
    Jul 27, 2006
    Messages:
    42
    Likes Received:
    1
    Trophy Points:
    6
    Actually I've changed my mind about the X-Anti-Abuse headers after reading about formmail holes and Bcc headers and such like. So I'll keep those.

    I've got rid of the MailScanner headers by changing them to X-Ignore in the MailScanner frontend settings. Now I just get an X-Ignore: ignore header, which is fine, if they block me because of that then fool them.

    However, I am still seeing, on outbound messages, a header saying X-Spam-Status: no - even though I've configured MailScanner to not scan for spam outbound. Adding such a header is just ridiculous anyway, it's not up to the judgement of my server to determine if a message is spam anyway, which is why so many antispam solutions (including SpamAssassin) will increase the spam score of a message that comes into a system with that header already set.

    How do I stop the X-Spam-Status: no header from being added to outbound mails please?

    Cheers,
    Steve
     
Loading...

Share This Page