The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Email will not send (Delivery Host: localhost)

Discussion in 'E-mail Discussions' started by fcomstoc, Mar 8, 2017.

  1. fcomstoc

    fcomstoc Member

    Joined:
    Jun 6, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    Hello Everyone,

    I have an issue with one of my accounts, for some reason the client is not receiving email from the form (EXIM). According to the Delivery Event Details, the Email is being sent to:

    Delivered To: :blackhole:
    Delivery Host: localhost

    Screenshot 2017-03-08 10.53.18.jpg

    I turned off all of the filters on outgoing mail, and checked the backlists to make sure the server is not on any. This account seems to be the only one with the issue as well.

    Does anyone have any idea why this might be happening or how to resolve it. I really don't know too much about email and thankfully we don't host any on the server, so I am at kind of a loss on this.

    Thank you,
    -Frank
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know the output from /var/log/exim_mainlog for that message? You can find the entry for that message with a command such as:

    Code:
    exigrep user@domain /var/log/exim_mainlog
    Also, are any email filters configured in cPanel for this account? Does the email address exist in "cPanel >> Email Accounts"?

    Thank you.
     
  3. fcomstoc

    fcomstoc Member

    Joined:
    Jun 6, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    Hello, here is the log for that message,

    Screenshot: Dropbox - Screenshot 2017-03-08 11.10.45.jpg

    There are no filters, the account being used is the default email account. I do have the unrouted email filter turned on, but that should only be fore incoming.

    Please let me know if this helps, I am happy to provide more info if needed.

    Thank you,
    -Frank
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    If the "Default Address" option in cPanel for this account is set to "Blackhole", and the delivery attempt is to an email account that does not exist under "Email Accounts" in cPanel, then the behavior you are noticing is by design. You'll need to create a separate email account for the cPanel account username, or modify the default address option.

    Thank you.
     
  5. fcomstoc

    fcomstoc Member

    Joined:
    Jun 6, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    So the email account I am sending to is not on this server, I host no email on the web sever. It should deliver to external email. The :blackhole: setting is for incoming email only, I used to have huge problems with spam filling the hard drive.

    Because this is sending to external addresses there should be no :blackhole issue. The other odd thing is that the email delivers with no problems to Yahoo addresses.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Can you confirm the affected domain name does not exist in the /etc/localdomains file on the cPanel server?

    Thank you.
     
  7. fcomstoc

    fcomstoc Member

    Joined:
    Jun 6, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    That would seem to be the issue, for some reason the server thinks it should be sending email to itself, how do I remove that so that it will start sending email externally only?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    You can browse to "WHM >> DNS Functions >> Edit DNS Zone", select the domain name, and update the "Email Routing" setting to:

    "Remote Mail Exchanger"

    Thank you.
     
  9. fcomstoc

    fcomstoc Member

    Joined:
    Jun 6, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Las Vegas, NV, USA
    cPanel Access Level:
    Root Administrator
    Awesome, that worked perfectly. Thank you very much for your help.
     
    cPanelMichael likes this.
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see it's now working as expected. Thank you for updating us with the outcome.
     
Loading...

Share This Page