Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hi,

I have an email address [email protected]. I receive emails from my customers daily but when I reply them using Webmail, it doesn't deliver. And it happens only with Gmail recipients. This is the error I receive back to my email:
[removed - please attach images directly to the thread]

I have root access to my server.

Any help would be appreciated.

Best,
Muzammil Versiani
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hello @Muzammil Versiani

Without knowing anything about your mail configuration, can you confirm if you have a valid PTR, SPF and DKIM record associated with the domain?

Code:
host $yourdomainIP
Code:
dig txt $yourdomain.tld
Code:
dig txt default._domainkey.$yourdomain.tld
 
  • Like
Reactions: Muzammil Versiani
Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hello @Muzammil Versiani

Without knowing anything about your mail configuration, can you confirm if you have a valid PTR, SPF and DKIM record associated with the domain?

Code:
host $yourdomainIP
Code:
dig txt $yourdomain.tld
Code:
dig txt default._domainkey.$yourdomain.tld

Code:
host $yourdomainIP
YourIP.in-addr.arpa domain name pointer server.example.com.
Code:
dig txt example.com
; <<>> DiG 9.9.4-RedHat-9.9.4-61.el7 <<>> txt 173.82.243.108.ltd
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 29899
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;173.82.243.108.ltd.            IN      TXT

;; AUTHORITY SECTION:
ltd.                    1799    IN      SOA     demand.alpha.aridns.net.au. host                                                                                        master.donuts.co. 1533152081 1800 900 604800 86400

;; Query time: 47 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Thu Aug 02 00:35:40 PKT 2018
;; MSG SIZE  rcvd: 129
Code:
dig txt default._domainkey.example.com
; <<>> DiG 9.9.4-RedHat-9.9.4-61.el7 <<>> txt default._domainkey.example.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 51599
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;default._domainkey.example.com. IN   TXT

;; AUTHORITY SECTION:
.                       86392   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2018080100 1800 900 604800 86400

;; Query time: 27 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Thu Aug 02 00:38:54 PKT 2018
;; MSG SIZE  rcvd: 136
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hello @Muzammil Versiani

Based on the output you're providing it doesn't appear that your domain has an SPF or DKIM record associated with it. I will point out that to double check I ran the check with the domain that was in the original screenshot and found that both of these records exist.

Can you please provide the output from the exim main log at /var/log/exim_mainlog from when you're sending to Gmail? Furthermore can you please ensure that you're removing any identifying information like IP addresses and domain names when you reply to the forum posts?


Thanks!
 
  • Like
Reactions: Muzammil Versiani
Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hello @Muzammil Versiani

Based on the output you're providing it doesn't appear that your domain has an SPF or DKIM record associated with it. I will point out that to double check I ran the check with the domain that was in the original screenshot and found that both of these records exist.

Can you please provide the output from the exim main log at /var/log/exim_mainlog from when you're sending to Gmail? Furthermore can you please ensure that you're removing any identifying information like IP addresses and domain names when you reply to the forum posts?


Thanks!
Hi @cPanelLauren

This is what I found in exim_mainlog

Code:
2018-07-29 03:39:02 pid 596: SIGHUP received: re-exec daemon
2018-07-29 03:39:03 cwd=/var/spool/exim 5 args: /usr/sbin/exim -bd -q1h -oP /var/spool/exim/exim-daemon.pid
2018-07-29 03:39:03 exim 4.91 daemon started: pid=596, -q1h, listening for SMTP on port 25 (IPv6 and IPv4) port 587 (IPv6 and IPv4) and for SMTPS on port 465 (IPv6 and IPv4)
2018-07-29 03:39:03 cwd=/var/spool/exim 2 args: /usr/sbin/exim -qG
2018-07-29 03:39:03 Start queue run: pid=516
2018-07-29 03:39:03 End queue run: pid=516
2018-07-29 03:39:03 pid 596: SIGHUP received: re-exec daemon
2018-07-29 03:39:03 cwd=/var/spool/exim 5 args: /usr/sbin/exim -bd -q1h -oP /var/spool/exim/exim-daemon.pid
2018-07-29 03:39:03 exim 4.91 daemon started: pid=596, -q1h, listening for SMTP on port 25 (IPv6 and IPv4) port 587 (IPv6 and IPv4) and for SMTPS on port 465 (IPv6 and IPv4)
2018-07-29 03:39:03 pid 596: SIGHUP received: re-exec daemon
2018-07-29 03:39:03 cwd=/var/spool/exim 5 args: /usr/sbin/exim -bd -q1h -oP /var/spool/exim/exim-daemon.pid
2018-07-29 03:39:03 cwd=/var/spool/exim 2 args: /usr/sbin/exim -qG
2018-07-29 03:39:03 Start queue run: pid=532
2018-07-29 03:39:03 exim 4.91 daemon started: pid=596, -q1h, listening for SMTP on port 25 (IPv6 and IPv4) port 587 (IPv6 and IPv4) and for SMTPS on port 465 (IPv6 and IPv4)
2018-07-29 03:39:03 End queue run: pid=532
2018-07-29 03:39:03 cwd=/var/spool/exim 2 args: /usr/sbin/exim -qG
2018-07-29 03:39:03 Start queue run: pid=536
2018-07-29 03:39:03 End queue run: pid=536
2018-07-29 03:42:32 SMTP connection from [127.0.0.1]:49888 (TCP/IP connection count = 1)
2018-07-29 03:42:32 SMTP connection from (localhost) [127.0.0.1]:49888 closed by QUIT
2018-07-29 03:47:33 SMTP connection from [127.0.0.1]:49916 (TCP/IP connection count = 1)
2018-07-29 03:47:34 SMTP connection from (localhost) [127.0.0.1]:49916 closed by QUIT
2018-07-29 03:52:35 SMTP connection from [127.0.0.1]:49944 (TCP/IP connection count = 1)
2018-07-29 03:52:35 SMTP connection from (localhost) [127.0.0.1]:49944 closed by QUIT
2018-07-29 03:57:35 SMTP connection from [127.0.0.1]:49972 (TCP/IP connection count = 1)
2018-07-29 03:57:35 SMTP connection from (localhost) [127.0.0.1]:49972 closed by QUIT
2018-07-29 04:02:37 SMTP connection from [127.0.0.1]:50006 (TCP/IP connection count = 1)
2018-07-29 04:02:37 SMTP connection from (localhost) [127.0.0.1]:50006 closed by QUIT
2018-07-29 04:07:37 SMTP connection from [127.0.0.1]:50044 (TCP/IP connection count = 1)
2018-07-29 04:07:37 SMTP connection from (localhost) [127.0.0.1]:50044 closed by QUIT
2018-07-29 04:12:38 SMTP connection from [127.0.0.1]:50078 (TCP/IP connection count = 1)
2018-07-29 04:12:38 SMTP connection from (localhost) [127.0.0.1]:50078 closed by QUIT
2018-07-29 04:17:39 SMTP connection from [127.0.0.1]:50106 (TCP/IP connection count = 1)
2018-07-29 04:17:39 SMTP connection from (localhost) [127.0.0.1]:50106 closed by QUIT
2018-07-29 04:22:41 SMTP connection from [127.0.0.1]:50138 (TCP/IP connection count = 1)
2018-07-29 04:22:41 SMTP connection from (localhost) [127.0.0.1]:50138 closed by QUIT
2018-07-29 04:27:41 SMTP connection from [127.0.0.1]:50176 (TCP/IP connection count = 1)
2018-07-29 04:27:41 SMTP connection from (localhost) [127.0.0.1]:50176 closed by QUIT
2018-07-29 04:32:42 SMTP connection from [127.0.0.1]:50214 (TCP/IP connection count = 1)
"exim_mainlog" 4311L, 430831C
I think in this output, no IP or domain is mentioned so its fine?

Thank you
 
Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hi @cPanelLauren

My bad, I didn't see complete log, Here is the interesting part, when I was sending to gmail:

Code:
2018-08-01 23:38:34 1fkw13-0006Dq-RJ <= [email protected] H=mail-lj1-f170.google.com [209.**.208.***]:37149 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:[email protected] S=4369 [email protected]l.com T="Your campaigns have been paused for security reasons" for [email protected]
2018-08-01 23:38:34 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1fkw13-0006Dq-RJ
2018-08-01 23:38:34 1fkw13-0006Dq-RJ Sender identification U=example D=example.com [email protected]
2018-08-01 23:38:34 1fkw13-0006Dq-RJ SMTP connection outbound 1533148714 1fkw13-0006Dq-RJ example.com [email protected]
2018-08-01 23:38:34 1fkw13-0006Dq-RJ ** [email protected] R=dkim_lookuphost T=dkim_remote_smtp: all hosts for 'gmail.com' have been failing for a long time (and retry time not reached)
2018-08-01 23:38:34 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1fkw13-0006Dq-RJ
2018-08-01 23:38:34 SMTP connection from mail-lj1-f170.google.com [209.**.208.***]:37149 closed by QUIT
2018-08-01 23:38:34 1fkw14-0006Dx-5d <= <> R=1fkw13-0006Dq-RJ U=mailnull P=local S=5682 T="Mail delivery failed: returning message to sender" for [email protected]
2018-08-01 23:38:34 1fkw13-0006Dq-RJ Completed
2018-08-01 23:38:34 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1fkw14-0006Dx-5d
2018-08-01 23:38:34 1fkw14-0006Dx-5d Sender identification U=mailnull D=-system- S=mailnull
2018-08-01 23:38:34 1fkw14-0006Dx-5d => support <[email protected]> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <[email protected]> iEb/HSr+YVt/XQAAM/+z4A Saved"
2018-08-01 23:38:34 1fkw14-0006Dx-5d ** [email protected] ([email protected]) <[email protected]> R=lookuphost T=remote_smtp: all hosts for 'gmail.com' have been failing for a long time (and retry time not reached)
2018-08-01 23:38:34 1fkw14-0006Dx-5d Frozen (delivery error message)
 
Last edited by a moderator:
Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hello @cPanelLauren

I just sent an email and here is the output:

Code:
2018-08-02 01:10:23 1fkxRu-00029m-Qu <= [email protected] H=mail-lf1-f48.google.com [209.**.167.**]:40514 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:[email protected] S=4368 [email protected]l.com T="Your campaigns have been paused for security reasons" for [email protected]
2018-08-02 01:10:23 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1fkxRu-00029m-Qu
2018-08-02 01:10:23 1fkxRu-00029m-Qu Sender identification U=example D=example.com [email protected]
2018-08-02 01:10:23 1fkxRu-00029m-Qu SMTP connection outbound 1533154223 1fkxRu-00029m-Qu example.com [email protected]
2018-08-02 01:10:23 SMTP connection from mail-lf1-f48.google.com [209.**.167.**]:40514 closed by QUIT
2018-08-02 01:10:23 1fkxRu-00029m-Qu ** [email protected] R=dkim_lookuphost T=dkim_remote_smtp: all hosts for 'gmail.com' have been failing for a long time (and retry time not reached)
2018-08-02 01:10:23 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1fkxRu-00029m-Qu
2018-08-02 01:10:23 1fkxRv-00029t-8V <= <> R=1fkxRu-00029m-Qu U=mailnull P=local S=5676 T="Mail delivery failed: returning message to sender" for [email protected]
2018-08-02 01:10:23 1fkxRu-00029m-Qu Completed
2018-08-02 01:10:23 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1fkxRv-00029t-8V
2018-08-02 01:10:23 1fkxRv-00029t-8V Sender identification U=mailnull D=-system- S=mailnull
2018-08-02 01:10:23 1fkxRv-00029t-8V => support <[email protected]> R=virtual_user T=dovecot_virtual_delivery C="250 2.0.0 <[email protected]> 8AgUJa8TYltzIAAAM/+z4A Saved"
2018-08-02 01:10:23 1fkxRv-00029t-8V ** [email protected] ([email protected]) <[email protected]> R=lookuphost T=remote_smtp: all hosts for 'gmail.com' have been failing for a long time (and retry time not reached)
2018-08-02 01:10:23 1fkxRv-00029t-8V Frozen (delivery error message)
2018-08-02 01:11:11 SMTP connection from [127.0.0.1]:37942 (TCP/IP connection count = 1)
2018-08-02 01:11:11 SMTP connection from (localhost) [127.0.0.1]:37942 closed by QUIT
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hi @Muzammil Versiani

Thank you for that information. Do you have any sort of firewall software or something that could be blocking your connection? It looks like the server isn't able to make an outbound connection to Gmail at all.


Thanks!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hi @Muzammil Versiani

Today I added my email account ([email protected]***.com) to Gmail with secure POP3 and SMTP information. The emails are sending now but they are landing in SPAM
Are you saying that you added the account to send/receive through gmail? Can you run your domain through one of the mailserver configuration tools and let me know what the output is? There are a few but the following should work for you if you're not familiar with one: Newsletters spam test by mail-tester.com

Without including the domain or IP address can you provide the output from that?

Thanks!
 
Aug 1, 2018
10
2
3
Pakistan
cPanel Access Level
Root Administrator
Hi @cPanelLauren

I sent an email to the tool you provided from my "support" email using gmail interface. Then in report, I got 10/10.

All green checks, except one that says:
"You do not have a DMARC record".

Should I add one? The tool is guiding me as to how I can add DMARC record.

Thank you
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
HI @Muzammil Versiani


That's great, to hear then that means you *shouldn't* be getting marked as spam. Can you show me the output of the following:

Code:
cat /etc/resolv.conf
You can add a DMARC record but it shouldn't be required to send to gmail.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hi @Muzammil Versiani


That's great, it really means that you shouldn't be having resolution issues especially with google related services. At this point, I don't see any specific reason why you should be getting marked as spam by Gmail or be rejected by them. From what I understand at this time you are able to send mail anywhere else without issue, you have the proper DNS records associated with mail and your mail is not getting marked as spam elsewhere. To further troubleshoot this you may want to go to Gmail. They have postmaster tools that may be of assistance here: Postmaster Tools – Google

Thanks!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,304
1,250
313
Houston
Hi @Muzammil Versiani

I'm glad that seems to have helped! I'm happy to have been able to assist you. Please let us know if you have any further questions or issues.

Thanks!
 
  • Like
Reactions: Muzammil Versiani