Emails do not work on addon domains

driverC

Well-Known Member
Jul 23, 2004
111
0
166
Hi,

I am having a real strange problem. When I log in to the email address of an addon domain I get the following error message:

Notice: (null)(): Retrying LOGIN authentication after AUTHENTICATE LOGIN failed (errflg=1) in Unknown on line 0
Notice: (null)(): Retrying LOGIN authentication after AUTHENTICATE LOGIN failed (errflg=1) in Unknown on line 0
Notice: (null)(): Can not authenticate to IMAP server: AUTHENTICATE LOGIN failed (errflg=2) in Unknown on line 0

The really strange this about this problem is that I can log in to other email addresses without problems. Even to email addresses that belong to other addon domains. Only for this specific addon domains all email addresses do not work. It does not accept the username and password. I tried to upgrade Cpanel and I tried to remove the email accounts and recreate them. I even removed the addon domain and recreated it without success. I am logging in with the full email address and everything. There seems to be some sort of bug that causes this problem. Any ideas ?
 

driverC

Well-Known Member
Jul 23, 2004
111
0
166
I found out that I can not connect via IMAP either as it is rejecting the password. However, I can connect via POP which indicates that the login I am using is correct. This does only effect email addresses under a specific domain name. I did already run /scripts/resetimappasswds but with no success :(
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
That is odd. Have you checked /var/log/maillog where the imap logins are logged, unless that's what you posted from?

Also, are you definitly running the cPanel IMAP daemon and not another one. On Linux systems it should be running /etc/xinetd.d/cpimap and no other one.

You could also try the usual suspects:

/scripts/updatedomains
/scripts/mailperm