Emails from cron to root

Rogerio

Well-Known Member
Sep 26, 2016
78
15
8
Sao Paulo, Brazil
cPanel Access Level
Root Administrator
Hello,

I'm not receiving emails from Cron, because it returns that [email protected] is invalid...

Like: (myhostname replaced the real fqn)

2018-11-06 10:42:02 1gK0gE-0006VR-Qs <= [email protected] U=root P=local S=815 T="Cron....

2018-11-06 10:42:02 cwd=/var/spool/exim 4 args: /usr/sbin/exim -odi -Mc 1gK0gE-0006VR-Qs
2018-11-06 10:42:02 1gK0gE-0006VR-Qs Sender identification U=root D=-system- S=root

2018-11-06 10:42:03 1gK0gE-0006VR-Qs ** [email protected] R=fail_remote_domains: The mail server could not deliver mail to [email protected] The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

2018-11-06 10:42:03 cwd=/var/spool/exim 8 args: /usr/sbin/exim -odi -t -oem -oi -f <> -E1gK0gE-0006VR-Qs
2018-11-06 10:42:03 1gK0gF-0006VX-14 <= <> R=1gK0gE-0006VR-Qs U=mailnull P=local S=2172 T="Mail delivery failed: returning message to sender" for [email protected]

In Edit System Mail Preferences the Forward mail for “root” to is correct to my real email.

Where is the problem?
Thanks.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,252
313
Houston
Hi @Rogerio

You'll need to set that mailto to whatever email address you want cron jobs to send mail to. I'm assuming at some point it got changed as the mailto= portion isn't usually filled out.
 
  • Like
Reactions: Rogerio