Emails not being received but no errors

Mugoma

Well-Known Member
Aug 1, 2016
74
4
8
Nairobi
cPanel Access Level
Root Administrator
We host the domain example.com. Since Dec. 26 2016 no emails being received on the domain. When an email is send to the domain there's no error either.

A look at - Removed - shows many DNS errors, indicating there's a problem. But a look at the DNS settings for domain on the server shows there's no problem. Both NS and MX records are in place.

What could be causing DNS errors?

If MX records is a problem how comes there's no bounce message?
 
Last edited by a moderator:

Mugoma

Well-Known Member
Aug 1, 2016
74
4
8
Nairobi
cPanel Access Level
Root Administrator
The name servers have been running for 2 years without a problem.

On the registrar the name servers are specified and their IP addresses. What else is supposed to be specified?

My guess is there's a problem with named but don't know how to pinpoint it.

On DNS problem - One or more of your nameservers did not respond the person says the problem can be resolved using the following on named:

allow-query { all; };


But I checked named and didn't see any such entry:

# cat /etc/named.conf | grep allow-query

# less /etc/named.conf | grep allow
inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
/* make named use port 53 for the source of all queries, to allow
// Put files that named is allowed to write in the data/ directory:
allow-transfer { "none"; };
// All BIND 9 zones are in a "view", which allow different zones to be served
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

To update, it was determined the missing emails were due to an email filter added to the account that discarded previously undelivered emails.

Thank you.