The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emails not being sent

Discussion in 'E-mail Discussions' started by rstanley, Jun 14, 2007.

  1. rstanley

    rstanley Member

    Joined:
    Oct 20, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I am getting the following error and have a rather large queue of emails.

    delivering 1HxhNg-0005Xs-Qy
    LOG: MAIN PANIC
    failed to expand condition "${perl{democheck}}" for democheck router: Undefined subroutine &main::democheck called.

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkbx_autowhitelist}{$authenticated_id}}" for boxtrapper_autowhitelist router: Undefined subroutine &main::checkbx_autowhitelist called.

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkspam2}}" for checkspam2 router: Undefined subroutine &main::checkspam2 called.

    LOG: MAIN
    == address@address.com R=lookuphost defer (-1): lookuphost router failed to expand "${perl{mailtrapheaders}}": Undefined subroutine &main::mailtrapheaders called.\n


    I have forced an update of whm/cpanel
    Rebuilt the rpms
    forced an update of exim


    Does anyone have any clues why this is happening?

    Thanks

    Rob
     
  2. rstanley

    rstanley Member

    Joined:
    Oct 20, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    For info

    root@server1 [/etc]# lsattr /etc/exim*
    ------------- /etc/exim/perl
    ------------- /etc/exim/authtab
    ------------- /etc/exim.aclspam
    ------------- /etc/exim.conf
    ------------- /etc/exim.conf.buildtest
    ------------- /etc/exim.conf.dist
    ------------- /etc/exim.conf.localopts
    ------------- /etc/exim.conf.mailman2.dist
    ------------- /etc/exim.conf.mailman2.exiscan.dist
    ------------- /etc/exim.crt
    ------------- /etc/exim_deny
    ------------- /etc/exim_deny.pl
    ------------- /etc/exim_deny_whitelist
    ------------- /etc/exim.key
    ------------- /etc/eximmailtrap
    ------------- /etc/exim.pl.local
    ------------- /etc/eximrejects
    ------------- /etc/eximrejects.rpmorig
     
  3. TSJasonH

    TSJasonH Active Member
    PartnerNOC

    Joined:
    Nov 25, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Chicago, IL
    Rob,

    Have you converted over to maildir yet? If you're running cP 11, then you'll need to do this to get exim running properly. Just run /scripts/convert2maildir to get it going.
     
  4. rstanley

    rstanley Member

    Joined:
    Oct 20, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Jason

    maildir is enabled when I run the command.

    Rob
     
  5. webstyler

    webstyler Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    432
    Likes Received:
    0
    Trophy Points:
    16
    same problem here :(

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkvalias}{$domain}{$local_part}}" for has_alias_but_no_mailbox_discarded_to_prevent_loop router: syntax error in Exim::expand_string argument: failed to open /etc/valiases/p10.mynetwork.net for linear search: No such file or directory at /etc/exim.pl.local line 564.

    LOG: MAIN PANIC
    failed to expand condition "${perl{checkvalias}{$domain}{$local_part}}" for has_alias_but_no_mailbox_discarded_to_prevent_loop router: syntax error in Exim::expand_string argument: failed to open /etc/valiases/p10.mynetwork.net for linear search: No such file or directory at /etc/exim.pl.local line 564.

    LOG: MAIN
    ** domain@mysite.com <nobody@p10.mynetwork.net> R=fail_remote_domains: unrouteable mail domain "mysite.com"
     
    #5 webstyler, May 22, 2009
    Last edited: May 22, 2009
Loading...

Share This Page