Emails to AOL being delayed, then rejected

GoWilkes

Well-Known Member
Sep 26, 2006
613
25
168
cPanel Access Level
Root Administrator
I'm having an odd issue with AOL that has recurred 3 times now, with 3 different AOL recipients. Each time, I've sent an email with no problem, then they reply. Then when I reply back, it's returned with this somewhat generic error:

From: Mail Delivery System [mailto:[email protected]]
Sent: Saturday, November 07, 2015 9:25 PM
To: [email protected]
Subject: Mail delivery failed: returning message to sender

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[email protected]
host mailin-03.mx.aol.com [12.34.56.78]
SMTP error from remote mail server after initial connection:
421 mtaig-mae04.mx.aol.com Service unavailable - try again later:
retry timeout exceeded

Reporting-MTA: dns; myserver.example.com

Action: failed
Final-Recipient: rfc822;[email protected]
Status: 5.0.0
Remote-MTA: dns; mailin-03.mx.aol.com
Diagnostic-Code: smtp; 421 mtaig-mae04.mx.aol.com Service unavailable - try again later: retry timeout exceeded
My Senderbase reputation is Neutral, and MXToolbox shows that I'm not on any blacklists.

Can anyone suggest whether this issue is on my end or AOL's? Either way, is there anything I can do to fix it on my end?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463

GoWilkes

Well-Known Member
Sep 26, 2006
613
25
168
cPanel Access Level
Root Administrator
Hmm. Thanks, Michael.

I went through all of the steps listed, and everything checks out perfectly. I've had an SPF Filter, DMARC policy, and DKIM key set up for at least a year, and running "dig" as instructed returned exactly what I thought.

The only warning from MXToolbox says that Reverse DNS doesn't match the SMTP Banner. I did some research and found references to changing it at /etc/exim.conf, but it's currently the default and I have no idea what should be changed:

"${primary_hostname} ESMTP Exim ${version_number} \#${compile_number} ${tod_full} \n We do not authorize the use of this system to transport unsolicited, \n and/or bulk e-mail."
Could this be the reason it's being rejected intermittently? If so, how should I edit it?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Have you verified the RDNS entry for your IP address matches the hostname of the server?

Thank you.