The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emails to root are not being redirected

Discussion in 'E-mail Discussions' started by bastek72pl, Nov 20, 2007.

  1. bastek72pl

    bastek72pl Member

    Joined:
    Apr 19, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I have this issue since 4 weeks maybe. All messages going to root get stuck in the exim queue with the error "root@server.mydomain.com R=lookuphost defer (-1): remote host address is the local host", even though, according to the server contacts setup, these should go to admin@mydomain.com.

    Could anyone help on this please?
     
  2. Danny_T

    Danny_T Well-Known Member

    Joined:
    Jul 19, 2005
    Messages:
    181
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Netherlands
    Try edit /etc/aliasses
     
  3. WebScHoLaR

    WebScHoLaR Well-Known Member

    Joined:
    Dec 14, 2005
    Messages:
    511
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Planet Earth

    You can also add admin@mydomain.com to /root/.forward file
     
  4. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I already have a /root/.forward forwarding those mails but still had the problem.

    Then I found Chirpy's posting here, and this solved it:

    http://forums.cpanel.net/showthread.php?t=63833

    I added my server's FQDN (hostname) to /etc/localdomains and it works great now.

    - Scott
     
    #4 sneader, Dec 9, 2007
    Last edited: Dec 9, 2007
Loading...

Share This Page