Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

emails to root bounce -- site with same domain as hostname

Discussion in 'E-mail Discussion' started by dcusimano, Feb 24, 2008.

  1. dcusimano

    dcusimano Member

    Joined:
    Feb 24, 2008
    Messages:
    16
    Likes Received:
    5
    Trophy Points:
    53
    Location:
    Toronto, Ontario, Canada
    Emails generated internally by my server that are addressed to the root (i.e.: root@ns.bime.com) are bouncing and not getting to the server's root email account.

    My server's hostname is ns.bime.com and I also have a website on the server with the domain bime.com (I previously went into cPanel and added a new website "bime.com" so that www.bime.com shows a website).

    The log file /var/log/exim_mainlog shows that the server is trying to send to root@ns.bime.com but bouncing. I assume this is happening because the website bime.com has no subdomain "ns.bime.com" and thus there's no email server to connect to. What do I change to get root@ns.bime.com to go to the root email account ("/var/spool/mail/root") of the server?

    Excerpt of /var/log/exim_mainlog showing cronjob email and bounce:

    --------

    [root@ns new]# egrep -e "(1JTL9q-0003m8-2q|1JTL9q-0003mC-7p)" /var/log/exim_mainlog
    2008-02-24 13:01:02 1JTL9q-0003m8-2q <= root@ns.bime.com U=root P=local S=1175 T="Cron <root@ns> run-parts /etc/cron.hourly"
    2008-02-24 13:01:02 cwd=/var/spool/exim 4 args: /usr/sbin/exim -odi -Mc 1JTL9q-0003m8-2q
    2008-02-24 13:01:02 1JTL9q-0003m8-2q User 0 set for local_delivery transport is on the never_users list
    2008-02-24 13:01:02 1JTL9q-0003m8-2q == root@ns.bime.com R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2008-02-24 13:01:02 1JTL9q-0003m8-2q ** root@ns.bime.com: retry timeout exceeded
    2008-02-24 13:01:02 cwd=/var/spool/exim 8 args: /usr/sbin/exim -odi -t -oem -oi -f <> -E1JTL9q-0003m8-2q
    2008-02-24 13:01:02 1JTL9q-0003mC-7p <= <> R=1JTL9q-0003m8-2q U=mailnull P=local S=1960 T="Mail delivery failed: returning message to sender"
    2008-02-24 13:01:02 cwd=/var/spool/exim 4 args: /usr/sbin/exim -odi -Mc 1JTL9q-0003mC-7p
    2008-02-24 13:01:02 1JTL9q-0003mC-7p User 0 set for local_delivery transport is on the never_users list
    2008-02-24 13:01:02 1JTL9q-0003mC-7p == root@ns.bime.com R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2008-02-24 13:01:02 1JTL9q-0003mC-7p ** root@ns.bime.com: retry timeout exceeded
    2008-02-24 13:01:02 1JTL9q-0003mC-7p root@ns.bime.com: error ignored
    2008-02-24 13:01:02 1JTL9q-0003mC-7p Completed
    2008-02-24 13:01:02 1JTL9q-0003m8-2q Completed
    [root@ns new]#

    --------

    Thanks.

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano
     
  2. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    Root Administrator
    hi,

    add ns.bime.com in /etc/localdomains
     
  3. dcusimano

    dcusimano Member

    Joined:
    Feb 24, 2008
    Messages:
    16
    Likes Received:
    5
    Trophy Points:
    53
    Location:
    Toronto, Ontario, Canada
    The very first two lines in /etc/localdomains already are as follows:

    ns.bime.com
    bime.com

    Again, the server hostname is ns.bime.com. And a website was added for domain bime.com. But that somehow broke root@ns.bime.com and that now bounces as shown in /var/log/exim_mainlog

    Yours truly,
    Cusimano.Com Corporation
    per: David Cusimano
     
  4. dynaweb

    dynaweb Well-Known Member

    Joined:
    May 14, 2003
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    158
    Location:
    Oregon
    Go into WHM -> SERVER CONTACTS -> CHANGE SYSTEM MAIL PREFERENCES and change the "root's mail" setting to something other than :fail:. If you want to receive all those messages, put an actual email address in there and if not then set to :blackhole:. There should be a warning in there that setting to :fail: creates an internal Exim bounce volley and is not recommended.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice