The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Emails with attachments getting rejected...

Discussion in 'E-mail Discussions' started by HorburySchool, Nov 27, 2008.

  1. HorburySchool

    HorburySchool Active Member

    Joined:
    Dec 14, 2007
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Have just been alerted by several of my users that attachments haven't been getting thru on email for a while...

    Checking /var/log/exim/mainlog I'm seeing the following frequently:

    Code:
    2008-11-27 18:02:15 1L5lBt-000KGR-U1 H=blu0-omc1-s1.blu0.hotmail.com [65.55.116.12] F=<realmusic@live.co.uk> temporarily rejected after DATA: failed to expand ACL string "${if eq {$spam_score_int}{}{0}{${if <= {${spam_score_int}}{8000}{${if >= {${spam_score_int}}{50}{${perl{store_spam}{$sender_host_address}{$spam_score}}}{0}}}{0}}}}": integer expected but "" found
    I've reset ACL Configs to default in WHM as was advised to fix in another thread... no difference. Issue affects various (but not all) accounts on the server across several domains... and it's been going on for quite some time by all accounts.

    Any help?

    Server: WHM 11.23.2 cPanel 11.23.4-R26157, FREEBSD 5.3-RELEASE-p5 i386 on standard - WHM X v3.1.0

    Here's the output from resetting ACL Configs and restarting Exim...

    Code:
    Your Exim configuration has been reset to the defaults.
    
    @!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!
    Warning, you are running an old version of exim that cannot fight spam as well as newer versions.  You should update to exim 4.68 or later as soon as possible.
    .@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!@!
    Configuration file passes test!  New configuration file was installed.
    Enabled system filter options: attachments|fail_spam_score_over_200|spam_rewrite
    Enabled ACL options in block ACL_RATELIMIT_SPAM_BLOCK: ratelimit_spam_score_over_200
    Enabled ACL options in block ACL_RATELIMIT_BLOCK: 0tracksenders
    Enabled ACL options in block ACL_RBL_BLOCK: 
    Enabled ACL options in block ACL_PRE_RECP_VERIFY_BLOCK: dictionary_attack
    Enabled ACL options in block ACL_NOTQUIT_BLOCK: 
    Enabled ACL options in block ACL_TRUSTEDLIST_BLOCK: trustedmailhosts
    Enabled ACL options in block ACL_CONNECT_BLOCK: spammerlist
    Enabled ACL options in block ACL_SPAM_BLOCK: deny_spam_score_over_200
    Detected spam handling in acls, disabling spamassassin in routers & transports!.
    SpamAssassin method remains unchanged
    Configured options list is: 
    acl_notquit is empty.. excluding this acl.
    Provided options list is: hostlist senderverifybypass_hosts|hostlist skipsmtpcheck_hosts|hostlist spammeripblocks|hostlist backupmx_hosts|hostlist trustedmailhosts|domainlist user_domains|smtp_receive_timeout|ignore_bounce_errors_after|timeout_frozen_after|auto_thaw|callout_domain_negative_expire|callout_negative_expire|acl_smtp_connect|spamd_address
    Exim Insert Regex is: virtual_userdelivery|virtual_aliases|lookuphost|virtual_user|address_pipe|localuser
    Exim Replace Regex is: virtual_sa_user|sa_localuser|virtual_sa_userdelivery|local_sa_delivery|central_filter|central_user_filter|democheck|fail_remote_domains|has_alias_but_no_mailbox_discarded_to_prevent_loop|literal|local_delivery|local_delivery_spam|localuser|localuser_spam|lookuphost|remote_smtp|userforward|virtual_aliases|virtual_aliases_nostar|virtual_user|virtual_user_spam|virtual_userdelivery|virtual_userdelivery_spam
    Exim Match Insert Regex is: quota_directory|maildir_format
    Exim version 4.64 #0 (FreeBSD 5.3) built 25-Dec-2006 00:29:08
    Copyright (c) University of Cambridge 2006
    Probably Berkeley DB version 1.8x (native mode)
    Support for: crypteq iconv() IPv6 use_setclassresources PAM Perl OpenSSL Content_Scanning Old_Demime
    Lookups: lsearch wildlsearch nwildlsearch iplsearch cdb dbm dbmnz dnsdb dsearch nis nis0 passwd
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir/mailstore/mbx autoreply lmtp pipe smtp
    Fixed never_users: 0
    Size of off_t: 8
    Exim Perl Load List is: spam_acl_support|checkuserquota|boxtrapper|safefile|fast_checkvalias|checkspam|checkspam2|fast_isdemo|fast_accountfunc|checkpass_cphulkd
    /etc/exim.pl.local installed!
    razor2 is not installed, disabling it in SpamAssassin to save memory
    pyzor is not installed, disabling it in SpamAssassin to save memory
    SPF is disabled in exim or unavailable, enabling SPF for SpamAssassin
    /scripts/mailscannerupdate: This script should not be run manually.  If you really wanted to do that, please add --force
    
    Attempting to restart exim 	
    Waiting for exim to restart.... . . . . . . . . . . finished. 
    Am running /scripts/eximup at the mo to see if it fixes anything...
     
    #1 HorburySchool, Nov 27, 2008
    Last edited: Nov 27, 2008
  2. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    I did a quick check on my /etc/exim.conf and I have this line

    Code:
    warn
          condition = ${if eq {$spam_score_int}{}{0}{${if <= {${spam_score_int}}{8000}{${if >= {${spam_score_int}}{50}{${perl{store_spam}{$sender_host_address}{$spam_score}}}{0}}}{0}}}}
    Which is exactly the same as yours....

    Are you using exim and spamd, mailscanner and exim or ASSP and exim or RVskin spam addon. Are you using any custom RBL or custom whitelists? Just thinking anything custom set by the above could have a glitch.

    You could try updating you cPanel installation, your is outdated.

    FreeBSD
    RELEASE
    11.23.6-RELEASE_27698
    (Fri Sep 26 18:38:14 2008)
     
  3. HorburySchool

    HorburySchool Active Member

    Joined:
    Dec 14, 2007
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Am using mailscanner & exim... no custom anythings - have reset all to defaults then ran /scripts/eximup and /scripts/mailscannerupdate --force

    Hadn't realised I was outdated - shall update now and let you know the outcome... Ta!
     
    #3 HorburySchool, Nov 27, 2008
    Last edited: Nov 27, 2008
  4. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Are you using configserver's mailscanner? If so did they install it for you?
     
  5. HorburySchool

    HorburySchool Active Member

    Joined:
    Dec 14, 2007
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    Righty... left cPanel update running overnight (it took a while!). Am now running WHM 11.23.2 cPanel 11.23.6-R27698.

    Hasn't fixed the issue tho, error message is as it was above.

    Everything installed was doneso by cPanel's scripts... not running mailscanner - am getting this server confused with another... sorry!

    Anyways... running Exim4.69, BoxTrapper Spam Trap, Mailman, SpamAssassin Spam Filter, SpamAssassin Spam Box.

    Dunno what I've just done, but it now appears to have fixed itself. A huge wodge of emails just landed, including all the test mails I was sending lastnight / yesterday. Only thing I've changed this morning was to re-enable the spamhaus and spamcop RBLs in Exim Config Editor after resetting all to defaults yesterday prior to update. *shrug*

    So... er... appears to have sorted itself out over the half an hour I've been typing this post for (whilst being interrupted by kids wanting profiles reset, teachers moaning about projectors etc)!
     
  6. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    It was most likely checking those boxes, everything I have seen on this erro had to do with RBL's. Glad it is working for you.
     
Loading...

Share This Page