Emergency Case, Apache fails every 3 minutes with end-less search for fix..

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
Hello all, i have CentOS 4.3 x86_64

Apache is failing every 3 minutes and here's the errors i get in my /usr/local/apache/error_logs , i have rebuilt it about 20 times with no fix and downloaded also the glibc rpms and forced an rpm update and rebuilt apache after that but also the same issue.



*** glibc detected *** corrupted double-linked list: 0x0000000000fce4e0 ***
*** glibc detected *** corrupted double-linked list: 0x0000000000fce4e0 ***
*** glibc detected *** corrupted double-linked list: 0x0000000000ddbf90 ***


*** glibc detected *** double free or corruption (!prev): 0x000000000121e370 ***
[Sat Apr 8 10:02:07 2006] [notice] child pid 26748 exit signal Aborted (6)


Mar 14 07:32:23 server httpd: *** glibc detected *** double free or corruption (out): 0x00007fffff83d870 ***
 

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
yes, i have just installed new zendoptimizer and i've rebuilt apache after that, anyway ill reinstall zendoptimizer now again and see what's going to be.. :rolleyes:
 

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
ok, i've stopped it from php.ini and still high loads and a lot of httpd processes.. i ave now only eaccelerator ! any idea ?
 

WEB-PROS

Well-Known Member
Feb 19, 2006
110
0
166
Have you recently installed Zend Optimiser?
If so rebuild apache with out it, tell whm to rebuild apache httpd.conf


if not you need to reinstall apache completly, this error means there is a error in the code.

Hope this helps.
 

WEB-PROS

Well-Known Member
Feb 19, 2006
110
0
166
Have you tried a server reboot, this may help., if this does not reply back and i will have a think.
 

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
i've been diging for this issue from about a week now but today it's gone critical and had to open a support ticket with my DC to contact cPanel, also i did now a rebuild apache and i recognized this lines at the bottom of the rebuilding page ...


####################################
Installing PHP SAPI module: cgi
Installing PHP CGI into: /usr/bin/
Installing PEAR environment: /usr/lib/php/
[PEAR] Archive_Tar: bad md5sum for file /usr/lib/php/Archive/Tar.php
[PEAR] Console_Getopt - already installed: 1.2
[PEAR] HTML_Template_IT- already installed: 1.1
[PEAR] Net_UserAgent_Detect- already installed: 2.0.1

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /home/cpapachebuild/buildapache/php-4.4.2/pear/PEAR/PackageFile/v2.php on line 241
initfpsuexec: using apache 1.x support
PHP version file has been updated to 4.4.2
Executing /scripts/postbuildapache (if exists)...Done
/etc/rc.d/init.d/httpd start: httpd started
####################################
 

WEB-PROS

Well-Known Member
Feb 19, 2006
110
0
166
Ok then, a few people have had the same problems looking around forums, alot of them had to complete recompile apache, i mean delete all files and start from new. Im not sure if this is totaly possible in WHM. In whm try and apache reinstall with basic php and other basic options try php 5.0.5. Also make sure it redoed httpd.conf and untick the Skip Apache Build if up to date and make sur rewrite module is ticked.

if not have a search for the keywords in your error in google, your not the only one out there with this error!!
 

nyjimbo

Well-Known Member
Jan 25, 2003
1,133
1
168
New York
"Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /home/cpapachebuild/buildapache/php-4.4.2/pear/PEAR/PackageFile/v2.php on line 241"

That bit above tells me that you are using up too much ram for the script, dont know why it would do that but did you try to increase the size of the

memory_limit = 8M

to something larger

in your php.ini and then try again ?
 

webignition

Well-Known Member
Jan 22, 2005
1,876
0
166
#mOdY# said:
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 92160 bytes) in /home/cpapachebuild/buildapache/php-4.4.2/pear/PEAR/PackageFile/v2.php on line 241
You could also try upping the amount of memory a cPanel process is allowed to use.

WHM > Tweak Settings > System
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
You're probably going to have to wait until cPanel have a look at it, especially since you're using 64bit Linux which is a minefield to support. Have you checked with your provider that they've logged it with cPanel?
 

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
ok, i've changed the memory value for all php.ini's i have on my box, i've rebuilt apache again and still cpu usage gets to high values between 15 to 25 and then reaches more high and the box be almost unavailable..any luck !? is there any chances i build my own apache/php say 2.0 or 2.2 but will cpanel accept that ? :rolleyes:
 

mOdY

Well-Known Member
Dec 25, 2004
80
0
156
chirpy said:
You're probably going to have to wait until cPanel have a look at it, especially since you're using 64bit Linux which is a minefield to support. Have you checked with your provider that they've logged it with cPanel?
Well, that's what i've already did and my DC opened up a ticket about 3 days ago and my DC replied that they got no reply from them although they signed the ticket priority as high, now i'm totaly lost and waiting for a cPanel action or a googling luck to fix my issue as cPanel support had gave me a bad impression now.... :(