BassTeQ

Active Member
Aug 31, 2008
43
3
58
Hi,

Looks like the local domlogs for each account are 0 bytes, any idea how to fix?

Substituted account details with "test"

[email protected] [/home/test/access-logs]# ls -ltr
-rw-r----- 2 root test 0 Aug 29 22:05 text.com-ssl_log
-rw-r----- 2 root test 0 Aug 29 22:05 test.com
drwxr-x--- 2 root test 4096 Aug 29 22:05 ./
drwx--x--x 18 root wheel 12288 Aug 31 19:33 ../

Appreciate any help.
Thanks
 

Bob1965

Member
Aug 30, 2018
23
3
3
Germany
cPanel Access Level
Root Administrator
Hi,

What are your settings in WHM for log processing?
WHM >> Statistics Software Configuration
Mine are set at 24 hours and show more than 0 bytes.
In the same window you can select the user "Test" and process the statistics manually.
Am not sure if the statistics are the same as the log processing but it is worth a shot.

You could also go to the directory /usr/local/apache/domlogs/test and try ls -ltr to see if the files have more that 0 bytes, maybe the symlink is broken or you do not have permission. I say this because the files are not stored in the directory you are checking, they are stored in /usr/local/apache/domlogs/.

Regards,
Bob
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,255
313
Houston
As indicated by @Bob1965 this can be due to a number of factors. The items suggested by him are relevant as well as taking into consideration any customizations like nginx. More information on your configuration may be necessary to provide an answer for you.

Thanks!
 

BassTeQ

Active Member
Aug 31, 2008
43
3
58
Thanks for the tips, I've checked /usr/local/apache/domlogs for a few accounts and they all have 0 byte files.
i also tried forcing a log update in WHM >> Statistics Software Configuration >> Process User Stastics

@cPanelLauren , I dont use nginx, what other details would be required to help troubleshoot? Am I better opening a support ticket perhaps?

Thanks
 

Bob1965

Member
Aug 30, 2018
23
3
3
Germany
cPanel Access Level
Root Administrator
You could also check your httpd.conf and make sure the CustomLog for each VirtualHost has not been disabled.
- Use nano or vi to edit the /etc/apache2/conf/httpd.conf
- search for CustomLog /etc/apache2/logs/domlogs/
if this has a # sign in front of it, the logging is disabled and it won't log anything.
Remove the # and save the httpd.conf, then restart httpd

Is just a thought, but if it is disabled someone must have disabled it.
 

BassTeQ

Active Member
Aug 31, 2008
43
3
58
Not sure if something updated overnight, some accounts now have data in their access logs, however some still don't.

Checking httpd conf for those problem accounts, I don't see any "CustomLog" entries within the virtualhost config.
Eg
CustomLog /usr/local/apache/domlogs/test.com combined
CustomLog /usr/local/apache/domlogs/test.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."

I have logging/stats enabled for all accounts, and checking in WHM it shows the stats process ran last night.

Thanks
 

Bob1965

Member
Aug 30, 2018
23
3
3
Germany
cPanel Access Level
Root Administrator
Well, sorry I cannot help anymore.. maybe you should try rebooting the server.
I had a similar problem with a low traffic website but not all sites. I disabled the piped logging in WHM and it started working in real time.
 

BassTeQ

Active Member
Aug 31, 2008
43
3
58
Thanks @Bob1965, I opened a support ticket and they were great in helping resolve the issue.
They basically disabled and re-enabled piped logging and things started working :)