The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enable 587 port in Exim

Discussion in 'E-mail Discussions' started by thewebhosting, Nov 28, 2008.

  1. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    I wish to enable port 587 to use as an alternative for SMTP 25. Can anybody tell me where can I enable it using SSH?
     
  2. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Use WHM
    Main >> Service Configuration >> Service Manager
    Check enabled for exim on another port, then type in your port

    Do not forget to open this port for you firewall if you are using one.
     
  3. hzJayJ

    hzJayJ Well-Known Member

    Joined:
    Nov 14, 2008
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    Hello,

    Are you using any firewall?

    If so make sure to enable the port 587 in the firewall.
     
  4. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Many thanks to rhenderson and hzJayJ!! :)

    FYI, I am using configserver firewall and enabled port 587 from WHM and Firewall.
     
  5. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Your're welcome, glad you got it going.
     
  6. docbreed

    docbreed Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    UPDATE::
    Rebooted Server and works fine...

    I did exactly this and is not working..

    Code:
    root@chicago1 [/etc/chkserv.d]# service exim restart
    Shutting down exim:                                        [  OK  ]
    Shutting down spamd:                                       [FAILED]
    Starting exim-587:                                         [  OK  ]
    Starting exim:                                             [  OK  ]
    Starting exim alt spool:                                   [  OK  ]
    Starting exim-smtps:                                       [  OK  ]
    
    Code:
    root@chicago1 [/etc/chkserv.d]# ps aux | grep exim
    mailnull 19390  0.0  0.0  10152   928 ?        Ss   10:06   0:00 /usr/sbin/exim -bd -oX 587
    mailnull 19394  0.0  0.0  10164   936 ?        Ss   10:06   0:00 /usr/sbin/exim -q60m
    mailnull 19400  0.0  0.0  10156   984 ?        Ss   10:06   0:00 /usr/sbin/exim -bd -odq -DSPOOL=/var/spool/exim_incoming
    mailnull 19403  0.0  0.0  10156   940 ?        Ss   10:06   0:00 /usr/sbin/exim -tls-on-connect -bd -oX 465
    root     20411  0.0  0.0   4780   660 pts/3    R+   10:07   0:00 grep exim
    
    CSF has port 587 open.. I've even disabled it and still cannot connect in.
    Also tried port 26 before 587
     
    #6 docbreed, Dec 10, 2008
    Last edited: Dec 10, 2008
  7. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Add the following to the first text box in the Exim Advanced Editor:
    daemon_smtp_ports = 25 : 587

    Scroll down and save and confirm that Exim restarts without errors.

    The additional instance of Exim running on port 587 won't be required.
     
  8. docbreed

    docbreed Well-Known Member

    Joined:
    Jul 18, 2005
    Messages:
    57
    Likes Received:
    0
    Trophy Points:
    6
    Even better.. Seen your post on other forums... Thanks alot works great!
     
  9. fire692

    fire692 Member

    Joined:
    Jul 20, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    This worked for me as well. Thank you!:)
     
Loading...

Share This Page