Enable comments on HTTP2 feature request

C

cPanelUser-Inactive

Guest
Done! If you'd like to discuss anything unrelated to that specific request, please do keep it over here!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
I'm guessing this has been delayed?
Hi @Gareth-AWD,

The EasyApache 4 maintenance release is now published. You can run "yum update" to update your system, and use the following command to install the HTTP2 package:

Code:
yum install ea-apache24-mod_http2
Documentation on the HTTP2 Apache module should become available soon.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
It's listing under EasyApache 4. Does running it via Easy Apache 4 automatically do the above command or do you need to do both?
You can choose to install the module using "WHM >> EasyApache 4" instead of the command line. You don't have to run that command if you install it through WHM.

What does when we are using from experimental repo ? How to update from production?
You can review the top answer on the corresponding feature request for information on how to remove the experimental version:

EasyApache 4 HTTP2 Support

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
752
28
78
cPanel Access Level
Root Administrator
You can review the top answer on the corresponding feature request for information on how to remove the experimental version:

EasyApache 4 HTTP2 Support

Thank you.
Do we need remove /etc/apache2/conf.d/http2.conf files? This http2.conf files added manually.

Code:
    # yum install ea4-experimental
    # yum install ea-apache24-mod_http2

Place this .conf file down in '/etc/apache2/conf.d/http2.conf'

    <IfModule http2_module>
        LogLevel http2:info
        Protocols h2 h2c http/1.1
    </IfModule>

Restart Apache

    /scripts/restartsrv_httpd
 

Ian Svoboda

Member
Mar 19, 2017
5
1
3
Jacksonville, FL
cPanel Access Level
Root Administrator
I seem to be unable to install mod_http2 via WHM. This is part of the error I received:

Code:
Error: Package: ea-apache24-mod_http2-2.4.25-11.14.1.cpanel.x86_64 (EA4)
Requires: ea-apache24 = 2.4.25-11.14.1.cpanel
Installed: 1:ea-apache24-2.4.25-9.el7.cloudlinux.3.x86_64 (@cl-ea4)
ea-apache24 = 1:2.4.25-9.el7.cloudlinux.3
Looks like EasyApache needs to receive some kind of update? I've run a system update but it told me there weren't any packages to update. I also updated cPanel for good measure, but still getting the error.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Installed: 1:ea-apache24-2.4.25-9.el7.cloudlinux.3.x86_64 (@cl-ea4) ea-apache24 = 1:2.4.25-9.el7.cloudlinux.3
Hello,

CloudLinux does not yet support this module. You can monitor their blog to see when they post an update to the cl-ea4 repo:

CloudLinux Blog

Thank you.