The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enable Event Sheduler in PHPMyAdmin

Discussion in 'Database Discussions' started by saikumar, Aug 22, 2016.

Tags:
  1. saikumar

    saikumar Registered

    Joined:
    Aug 22, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hyderabad
    cPanel Access Level:
    Root Administrator
    How to Turn ON EVENT SCHEDULER IN CPANEL PHPMYADMIN
    when i try to turn on it says


    Error:#1227 - Access denied; you need (at least one of) the SUPER privilege(s) for this operation

    AS i Have given All the Permissions in privileges Still It Says TO me What COuld be the Solution to Turn On THE event Scheduler
     
    #1 saikumar, Aug 22, 2016
    Last edited by a moderator: Aug 22, 2016
  2. syslint

    syslint Well-Known Member

    Joined:
    Oct 9, 2006
    Messages:
    249
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you running mysql in strict mode ?
     
  3. saikumar

    saikumar Registered

    Joined:
    Aug 22, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hyderabad
    cPanel Access Level:
    Root Administrator
    No, and the other thing is that i cant find my.cnf/my.ini in my Server i,e CPANEL
     
  4. germany

    germany Member

    Joined:
    Jul 15, 2016
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Berlin, DE
    cPanel Access Level:
    Website Owner
    Just issue appropriate CREATE EVENT SQL from SQL box.

    However: your MySQL server needs to have event scheduler enabled AND have EVENT privileges for the database user.

    Calling SELECT @@event_scheduler; will tell you if the scheduler is available and enabled.

    To enable event scheduler if it's disabled try calling SET GLOBAL event_scheduler := 1; You need the SUPER privilege for this to succeed.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,682
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page