The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enable Nameserver

Discussion in 'Bind / DNS / Nameserver Issues' started by Tussin, Feb 11, 2005.

  1. Tussin

    Tussin Registered

    Joined:
    Feb 10, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ok ok, I have seached the forms for awhile now and I cant find anything maybe im blind or search engine incompetent.

    Im tryin get my Nameserver enabled

    I click Nameserver Setup on the left I get a screen that looks something like this

    Code:
    Enable Nameserver  
     
    We recommend you do not enable the nameserver unless you are going to use it. If you wish to disable the nameserver you can always turn it off in the Service Manager  
     
                                              ok
    I click ok to enable my nameserver It does this

    Code:
    Name Server Activated
    Ensuring caching-nameserver is installed
    Using RPM Backend: RPM version 4.2.1
    installed: caching-nameserver-7.2-10
    Activating nameserver monitoring
    Stopping chkservd: [  OK  ]
    Starting chkservd: [  OK  ]
    Starting Nameserver
        Attempting to restart named  
    Waiting for named to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.
    
    
        named status named     7261  0.1  0.4 11768 2472 ?        S    00:46   0:00 /usr/sbin/named -u named
    named     7264  0.0  0.4 11768 2472 ?        S    00:46   0:00 /usr/sbin/named -u named
    named     7265  0.1  0.4 11768 2472 ?        S    00:46   0:00 /usr/sbin/named -u named
    named     7266  0.0  0.4 11768 2472 ?        S    00:46   0:00 /usr/sbin/named -u named
    named     7267  0.0  0.4 11768 2472 ?        S    00:46   0:00 /usr/sbin/named -u named
     
            
    named started ok
    Feb 11 00:46:40 bob named[7140]: shutting down: flushing changes
    Feb 11 00:46:40 bob named[7140]: stopping command channel on 127.0.0.1#953
    Feb 11 00:46:40 bob named[7140]: no longer listening on 127.0.0.1#53
    Feb 11 00:46:40 bob named[7140]: no longer listening on xxx.xxx.xxx.xxx.#53
    Feb 11 00:46:40 bob named[7140]: no longer listening on xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7140]: no longer listening on xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7140]: no longer listening on xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7138]: exiting
    Feb 11 00:46:40 bob named:  succeeded
    Feb 11 00:46:40 bob named[7261]: starting BIND 9.2.2-P3 -u named
    Feb 11 00:46:40 bob named: named startup succeeded
    Feb 11 00:46:40 bob named[7261]: using 1 CPU
    Feb 11 00:46:40 bob named[7265]: loading configuration from '/etc/named.conf'
    Feb 11 00:46:40 bob named[7265]: no IPv6 interfaces found
    Feb 11 00:46:40 bob named[7265]: listening on IPv4 interface lo, 127.0.0.1#53
    Feb 11 00:46:40 bob named[7265]: listening on IPv4 interface eth0, xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7265]: listening on IPv4 interface eth0:1, xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7265]: listening on IPv4 interface eth0:2, xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7265]: listening on IPv4 interface eth0:3, xxx.xxx.xxx.xxx#53
    Feb 11 00:46:40 bob named[7265]: command channel listening on 127.0.0.1#953
    Feb 11 00:46:40 bob named[7265]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    Feb 11 00:46:40 bob named[7265]: zone domain.com/IN: loaded serial 2005021100
    Feb 11 00:46:40 bob named[7265]: zone bob.domain.com/IN: loaded serial 2005021001
    Feb 11 00:46:40 bob named[7265]: zone localhost/IN: loaded serial 42
    Feb 11 00:46:40 bob named[7265]: running
    Feb 11 00:46:40 bob named[7265]: zone bob.domain.com/IN: sending notifies (serial 2005021001)
    Feb 11 00:46:40 bob named[7265]: zone domain.com/IN: sending notifies (serial 2005021100)
    I have let it sit here for a half hour, but nothing else happends, at first I thought ok everthing is ok. When i click on nameserver setup agian it goes back and asked me to press ok to enable my name server and goes threw the same process.

    So how do i get my nameserver enabled ?
    I have tried restarting the cpannel service
    and I have tried restarting Bind
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Erm, the final output you posted shows named starting up just fine. That setting in WHM always shows the same screen whether it is enabled or not. To confirm that named is running run from root shell:

    rndc status
     
  3. Tussin

    Tussin Registered

    Joined:
    Feb 10, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    ahh thanks, I think stupidity got the best of me agian
     
Loading...

Share This Page