The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

enable open_basedir for one user

Discussion in 'General Discussion' started by asmithjr, Nov 26, 2007.

  1. asmithjr

    asmithjr Well-Known Member

    Joined:
    Jun 13, 2003
    Messages:
    475
    Likes Received:
    1
    Trophy Points:
    18
    Runing

    WHM 11.11.0 cPanel 11.15.0-C17981
    REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0

    I have Enable php open_basedir Protection checked and have 2 users that need to share files in their images folder (actually one shares the other reads)

    I checked both users Exclude Protection (even tried with just one or the other)

    I cannot seem to get this to work. I even tried turning off the Enable php open_basedir Protection (unchecking)
     
  2. Michel McA

    Michel McA Member
    PartnerNOC

    Joined:
    Sep 1, 2007
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Make sure you are altering the right php.ini file

    php-i|grep php.ini

    Also make sure the /usr/local/apache/conf/httpd.conf has been edited

    <VirtualHost ip address/ and or account you wish to edit here.>
    .......
    .......
    <IfModule mod_php4.c>
    php_admin_value open_basedir "arguement"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "arguement"
    </IfModule>
    ........
    </VirtualHost>
     
  3. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    First - what is your cPanel version?

    Second - how are the users attempting to access the files? Are they using include, open, what?

    Third - what errors are the users receiving when attempting to access the files?

    Fourth - did you verify the open_basedir directives were removed from their respective VirtualHost entries?
     
Loading...

Share This Page