The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enable or install mod_security

Discussion in 'Security' started by alexandz, Dec 22, 2011.

  1. alexandz

    alexandz Well-Known Member

    Joined:
    Oct 28, 2011
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    Hello! I have installed csf and this requires that mod_security is enabled, so my question is. Enable this module affect you?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm sorry I don't understand the question. Are you asking how to install mod security?

    You can install mod_security in WHM under Plugins.
     
  3. asturmas

    asturmas Well-Known Member
    PartnerNOC

    Joined:
    Jun 19, 2006
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Portugal
    cPanel Access Level:
    DataCenter Provider
    Under plugins or in easyapache?...
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes, via EasyApache sorry, apparently not awake yet today.
     
  5. alexandz

    alexandz Well-Known Member

    Joined:
    Oct 28, 2011
    Messages:
    111
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Chile
    cPanel Access Level:
    Root Administrator
    And when you install will have a problem?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,481
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    That's a broad question. Yes, there is a chance that some rules will interfere with some scripts you need to run on the server.
    Thankfully we have the use of this tool which makes managing mod_security as needed per account, easy:
    ConfigServer ModSecurity Control
     
Loading...

Share This Page