SOLVED Enable SNI for Primary Domain

Operating System & Version
CENTOS 7.8
cPanel & WHM Version
v90.0.16

DHarry

Member
Nov 9, 2016
12
1
3
Kansas City, Missouri
cPanel Access Level
Root Administrator
My "primary domain" is receiving an odd 421 Misredirect Error.

The full error reads: " The client needs a new connection for this request as the requested host name does not match the Server Name Indication (SNI) in use for this connection. "

In WHM, under the Manage SSL Host section, the primary domain, it the "Is SNI Required?" field is marked "No".

I imagine this pertains to my error in some way but if so, is there a way to mark it "Yes"? I've read the documentation here but I don't see a way to configure this section: https://docs.cpanel.net/whm/ssl-tls/manage-ssl-hosts/
 

cPanelAaronH

Well-Known Member
Staff member
Dec 31, 2014
70
19
133
Houston Texas
cPanel Access Level
Root Administrator
Hello,

cPanel has supported and enabled SNI since version 11.38 or newer as long as the server is running CentOS 6 or higher. Is the server currently running http2?

Code:
rpm -qa |grep ea-apache24-mod_http2.x86_64
 
  • Like
Reactions: DHarry