The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enable Telnet

Discussion in 'General Discussion' started by mickalo, Jul 7, 2004.

  1. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Need to enable telnet temporarly.. and followed everything need to enable it, opened port 23 in our firewall IG_TCP_CPORTS (inbound ports), restarted xinetd and apf, changed the disable=yes to no in the /etc/xinetd.d/telnet file, but it still won't let me telnet into the server... just need to enable it, just incase I get locked out of ssh while making some changes.

    is there something I missed ?

    TIA,
    Mickalo
     
  2. akhthar

    akhthar Member

    Joined:
    May 4, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    bangalore
    Hello,

    It looks like you have set the iptables in your system. So check it out. Mostly there you have to allow port number 23.

    :)
     
  3. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    I use APF firewall and opened Port 23, restarted APF, and still didn't work :)

    Mickalo
     
  4. akhthar

    akhthar Member

    Joined:
    May 4, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    bangalore
    Hello,

    I had a similar problem before. But at that time I used the apf and iptables for security. And I have enabled that port in apf. And I was using iptables to block all ports other than allowed ports. So I added a line to allow access to that port.

    :)
     
  5. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    what line did you add and where ??

    Mickalo
     
  6. akhthar

    akhthar Member

    Joined:
    May 4, 2004
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    bangalore
    Hello,

    In /etc/sysconfig/iptables

    [0:0] -A INPUT -p tcp --dport 23 -j ACCEPT
     
  7. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    Ok, I'll give a shot and see what happens.

    thx's for the help :)

    Mickalo
     
  8. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Looks like you have everything.

    Did you run:

    iptables -A INPUT -p tcp --dport 23 -j ACCEPT

    just to make sure it was opened?

    If that doesn't work, connect via SSH try to connect via telnet and take a look at the output of

    tail /var/log/messages

    and

    tail /var/log/apf_log

    for more insight.
     
  9. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    765
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    N.W. Iowa
    I assume this would be the command line to open the port w/iptables ??

    then how would one drop/close the port afterwards so the port would no longer be open ??

    Mickalo
     
  10. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    Reversing the changes you made and restarting apf should do the trick, but if you want to do it explicitly just change the ACCEPT to DROP ;)
     
  11. sebby

    sebby Well-Known Member

    Joined:
    Jun 15, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Same thing here, I need to enable telnet temporarly to prevent being locked out of the box while I'm securing my server (changing ssh config and all...)

    However unable get telnet working... my server is not listening on port 23...

    Any suggestions ?

    Thanks in advance.

    Seb
     
  12. sebby

    sebby Well-Known Member

    Joined:
    Jun 15, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    But for security issues, any reason why telnet is not enabled in original settings of cPanel (on Fedora Core 1) ? I have yet no firewall installed and I'm in the process of securing my server's box (working around ssh : changing ip, port, disable root login, etc...). Want to enable telnet during this process in case I do something wrong... Don't understand why Telnet it is not working and didn't find anything related on this forum. Looks like everything sent to port 23 is dropped...

    Any suggestions would be most appreciated.

    Seb

    p.s. I tried the workarounds described above in this thread but no success
     
  13. sebby

    sebby Well-Known Member

    Joined:
    Jun 15, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Any suggestion for a newbie ?

    Maybe I should start to cross post...
     
  14. sebby

    sebby Well-Known Member

    Joined:
    Jun 15, 2004
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    6
    Anyone ? :rolleyes:
     
  15. WillyMore

    WillyMore Active Member

    Joined:
    May 22, 2002
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    iptables -A INPUT -p tcp --dport 23 -j ACCEPT

    Worked for me Thanks
     
  16. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Please don't re-open a year old thread for this, it's really not necessary :)
     
Loading...

Share This Page