The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enabled mysqlnd

Discussion in 'EasyApache' started by ShawnL, Jul 25, 2016.

  1. ShawnL

    ShawnL Member

    Joined:
    Mar 3, 2016
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    My server runs CloudLinux 5 and EasyApache 3.

    For one cPanel account's "Select PHP Version," I chose PHP 5.6 and checked "mysqlnd."

    phpinfo() shows mysqlnd is enabled, but pdo_mysql is not using it.

    Code:
    pdo_mysql
    PDO Driver for MySQL enabled
    Client API version 5.5.50
    
    It's not mentioning "mysqlnd."

    Here is the Configure Command:
    Code:
    './configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/opt/alt/php56' '--exec-prefix=/opt/alt/php56' '--bindir=/opt/alt/php56/usr/bin' '--sbindir=/opt/alt/php56/usr/sbin' '--sysconfdir=/opt/alt/php56/etc' '--datadir=/opt/alt/php56/usr/share' '--includedir=/opt/alt/php56/usr/include' '--libdir=/opt/alt/php56/usr/lib64' '--libexecdir=/opt/alt/php56/usr/libexec' '--localstatedir=/var' '--with-curl=/opt/alt/curlssl/usr' '--sharedstatedir=/usr/com' '--mandir=/opt/alt/php56/usr/share/man' '--infodir=/opt/alt/php56/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/opt/alt/php56/etc' '--with-config-file-scan-dir=/opt/alt/php56/link/conf' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--with-t1lib=/opt/alt/t1lib/usr' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/opt/alt/pcre/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-sockets=shared' '--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-sysvmsg=shared' '--with-kerberos' '--enable-shmop' '--enable-calendar' '--with-libxml-dir=/opt/alt/libxml2/usr' '--enable-xml' '--with-mcrypt=shared,/usr' '--with-tidy=shared,/usr' '--with-readline' '--with-mhash' '--enable-dbx=shared' '--with-zlib-dir=/usr' '--disable-opcache' '--with-mssql=shared,/opt/alt/freetds/usr' '--with-pdo-dblib=shared,/opt/alt/freetds/usr' '--enable-phpdbg' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--enable-dom=shared' '--with-pgsql=shared' '--enable-wddx=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-icu-dir=/opt/alt/libicu/usr' '--enable-fastcgi' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/opt/alt/sqlite/usr' '--enable-json=shared' '--enable-zip=shared' '--with-pspell=shared' '--enable-phar=shared' '--enable-posix=shared' '--with-unixODBC=shared,/usr' '--enable-fileinfo=shared' '--enable-intl=shared' '--enable-sqlite3=shared,/opt/alt/sqlite/usr' '--with-enchant=shared,/usr' '--with-sybase-ct=shared,/opt/alt/freetds/usr' '--with-recode=shared,/usr' 'CFLAGS=-O2 '-g' '-pipe' '-Wall' '-Wp,-D_FORTIFY_SOURCE=2' '-fexceptions' '-fstack-protector' '--param=ssp-buffer-size=4' '-m64' '-mtune=generic' '-fno-strict-aliasing' '-Wno-pointer-sign'' 'LDFLAGS= '-Wl,-rpath=/opt/alt/curlssl/usr/lib64,-rpath=/opt/alt/libssh2/usr/lib64,-rpath=/opt/alt/libxml2/usr/lib64,-rpath=/opt/alt/pcre/usr/lib64,-rpath=/opt/alt/t1lib/usr/lib64,-rpath=/opt/alt/freetds/usr/lib64,-rpath=/opt/alt/sqlite/usr/lib64,-rpath=/opt/alt/libicu/usr/lib64' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'target_alias=x86_64-redhat-linux-gnu'
    
    
    What should I do?
     
    #1 ShawnL, Jul 25, 2016
    Last edited by a moderator: Jul 25, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. ShawnL

    ShawnL Member

    Joined:
    Mar 3, 2016
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    US
    cPanel Access Level:
    Root Administrator
    I'm running PHP 5.6. In your documentation it says MySQL of the System is disabled for PHP 5.6. So that shouldn't be the problem.

    Here is an additional information I found: http://php.net/manual/en/mysqlinfo.library.choosing.php

    If you look at my phpinfo(), you'll see there is nothing related to mysql under configure command. Perhaps I should include the following to the configure command as suggested in the above link?

    ./configure --with-mysqli --with-pdo-mysql --with-mysql

    How do I do that properly with cPanel/WHM?

    I have multiple cPanel accounts. Each account uses different PHP versions. The default is PHP 5.3. This account that I need to set mysqlnd as the active driver uses PHP 5.6.

    Thanks!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    This suggests you are using the PHP Selector feature with Cloud Linux, as EasyApache 3 does not offer a multi-PHP environment. Please report this issue to the CloudLinux support team and let us know the outcome:

    CloudLinux - Main | New template

    Thank you.
     
Loading...

Share This Page