The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

enablefileprotect takes a lot of time

Discussion in 'EasyApache' started by nunoperalta, Dec 25, 2014.

  1. nunoperalta

    nunoperalta Registered

    Joined:
    Jan 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,

    At the end of EasyApache, "enablefileprotect" is run and it takes forever to complete.
    My file system is huge, with loads of inodes, so I believe this is the reason it takes a lot of time to complete.

    Even if I disable File Protection, it still runs and takes a long time to run, because it simply does the opposite.
    Is there any way I can disable this step completely, without having to change the script?

    By the way, this only seems to happen after a recent server migration. In my previous server, I am pretty sure this step didn't take so much time. Do you know what could be the cause for this process to take more time in the new server?

    I'm not sure if it helps, but the disk quotas is disabled, just like in the previous server.

    Thank you,
    Nuno
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. nunoperalta

    nunoperalta Registered

    Joined:
    Jan 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi Michael,

    Thank you for your reply. My ticket ID is 5925483.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,814
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, I see you opened a support ticket, but you requested that we do not access your server to investigate why "enablefileprotect" was taking an excessive amount of time. Feel free to reopen the ticket if you would like us to take a closer look at that. In the meantime, I see you opened this feature request:

    Skip File Protect routines completely in the Easyapache process | cPanel Feature Requests

    Thank you.
     

Share This Page