Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Enabling HTTP/2

Discussion in 'EasyApache' started by Goldalex, Aug 6, 2017.

Tags:
  1. Goldalex

    Goldalex Registered

    Joined:
    Aug 6, 2017
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    New York
    cPanel Access Level:
    Root Administrator
    I am sure that I'm missing a step someplace, but I'm trying to get HTTP/2 enabled on my site. I'm running mod_mpm_event with PHP 7.1 PHPFPM. I enabled the module, and checked that the http2.conf file is present which it is. I then go to check my site and when I load it in Chrome, I see that it's still being served as http 1.1. From what I can tell I've followed the proper steps.

    I am not running SSL and am using CloudFlare as a CDN and Http2/SPDY is enabled there.

    Thanks for the help.
     
  2. kdean

    kdean Well-Known Member

    Joined:
    Oct 19, 2012
    Messages:
    269
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    Orlando, FL
    cPanel Access Level:
    Root Administrator
    http/2 only works with https.
     
    Goldalex and cPanelMichael like this.
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The previous post is correct. You will only see HTTP2 when accessing the site using SSL (https://).

    Thank you.
     
    Goldalex likes this.
  4. Goldalex

    Goldalex Registered

    Joined:
    Aug 6, 2017
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    New York
    cPanel Access Level:
    Root Administrator
    Thanks all, I changed over to SSL and now all is functioning as expected with HTTP/2. I missed in the documentation where SSL was required. Apologize for that...Now on to figuring out why FPM isn't working on my site even though it's all configured. Have a ticket open for that though.
     
    cPanelMichael likes this.
Loading...

Share This Page