The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enabling PHP-FPM

Discussion in 'EasyApache' started by JanKrohn, Dec 22, 2016.

Tags:
  1. JanKrohn

    JanKrohn Active Member

    Joined:
    May 6, 2013
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Phnom Penh
    cPanel Access Level:
    Root Administrator
    Hi,

    I came across some claims that PHP-FPM would be more performant on busy sites, so I've tried to enable it. I have ~13,000 visitors per day.

    So I've read the cPanel documentation on FPM, enabled the missing modules in EA4, and switched FPM on for my main domain.

    It seemed to be running good for a few minutes, then got slower, and finally the site wouldn't load any longer.

    Switched FPM off and on again. Same thing. Site got slower, and went down.

    Any ideas how to troubleshoot? (I run PHP 7.1 and MariaDB 10.1, but also tested on PHP 7.0 with the same outcome...)

    Thanks!
    Jan
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any specific output to /var/log/apache2/error_log during the times when the website would not load?

    Thank you.
     
  3. JanKrohn

    JanKrohn Active Member

    Joined:
    May 6, 2013
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Phnom Penh
    cPanel Access Level:
    Root Administrator
    Indeed! There are a couple of error messages:

    The site wnt down at 13:13, and came back 13:18. Here all all (non ModSecurity related) error messages in between:

    Code:
    [Thu Dec 22 13:14:04.328899 2016] [proxy_fcgi:error] [pid 12786] (70007)The timeout specified has expired: [client 172.245.4.222:52146] AH01075: Error dispatching request to : (polling)
    [Thu Dec 22 13:23:17.711202 2016] [proxy_fcgi:error] [pid 14872] [client 113.199.200.133:49700] AH01071: Got error 'Primary script unknown\n'
    [Thu Dec 22 13:18:19.757029 2016] [mpm_prefork:error] [pid 12295] AH00161: servver reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    [Thu Dec 22 13:18:39.528963 2016] [mpm_prefork:notice] [pid 12295] AH00169: caught SIGTERM, shutting down
    [Thu Dec 22 13:18:42.404787 2016] [suexec:notice] [pid 14139] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
    [Thu Dec 22 13:18:42.613711 2016] [mpm_prefork:notice] [pid 14140] AH00163: Apache/2.4.23 (cPanel) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 configured -- resuming normal operations
    [Thu Dec 22 13:18:42.613734 2016] [core:notice] [pid 14140] AH00094: Command line: '/usr/sbin/httpd'
    Most of those messages occurred multiple times.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Please let us know if the information on the following thread helps:

    mod_proxy_fcgi configuration and settings

    Thank you.
     
  5. JanKrohn

    JanKrohn Active Member

    Joined:
    May 6, 2013
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Phnom Penh
    cPanel Access Level:
    Root Administrator
    Thanks! My performance issues were actually caused by lack of server resources. I have no more need now to switch to FPM.

    Best wishes,
    Jan
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,204
    Likes Received:
    1,297
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see you were able to address the primary issue. Thank you for updating us with the outcome.
     
Loading...

Share This Page