The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

enabling phpsuexec (Waiting)

Discussion in 'General Discussion' started by vishal, Apr 16, 2003.

  1. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    WHM 6.2.0
    Cpanel 6.4.0-S3
    RedHat 7.3

    If i enable PHPSuexec from the Easyapache script.
    How will i enable it for the php scripts?
    Do I need to do something EXTRAAA for it ?
    Will i get a option in WHM for the PHP suexec?
    Will it cause any harm for my server?

    As this is my last try for the mail() function of PHP to work!!!

    Rest I tried everything.

    Regards,
    :confused:
     
  2. joana

    joana Well-Known Member

    Joined:
    Sep 29, 2001
    Messages:
    103
    Likes Received:
    0
    Trophy Points:
    16
    after you install it, you have to change permissions on php scripts server wide. Have fun..
     
  3. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    We know all that! We need to know how to do it. Why is it so hard to get proper answer here?
     
  4. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    There is another thread which explains this step by step...

    Just do a seach !
     
  5. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Need to know the results!!

    Hello,

    I just want to know the consequences after installing phpsuexec ?

    Should i do it or not ?

    Does it depends on how u have configured the server.
    in that case i am on Manula Update (Stable Tree).

    Regards,
    :confused:
     
  6. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Resolved

    Hello,

    I managed to Resolved the mail() php problem.

    My problem was that the hostname i used for my server was not resolving correctly!!! and that is why the destination machine was not accepting my mails.

    I'll give the steps that worked for me!! Hope it Works for u also.

    1. I haven't installed PHPSuexec.
    2. Put the "Prevent nobody " OFF (Unchecked).
    3.In your exim.conf file check for
    qualify_domain = "this should be a valid domain"
    In my case this line was comment with no value i.e

    #qualify_domain =
    i changed it to
    qualify_domain = mydomain.com ==> Should be valid

    Then check
    never_user = root (root cannot send mails).

    try commenting and uncommeting it.

    sender_verify = true (verifyies sender address).

    comment it or make it false.

    if at all u got any confusion feel free to reply!!! I'll definately try to help u out. As i have spent 3 days and Nights just to make this stuff work.

    (I know what happens when mail dosen't work) :)

    Regards,

    Vishal.:D
     
  7. carperman

    carperman Well-Known Member

    Joined:
    Feb 7, 2002
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Re: Resolved

    what does this acheive? how does it differ from phpsuexec?



     
  8. carperman

    carperman Well-Known Member

    Joined:
    Feb 7, 2002
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16

    thanks for reply, but i was aware of that, what i wanted to know how vishal solution differs?
     
  9. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    I have heard many reports that PHPSuExec is far too buggy.

    I'm also not about to chmod ALL the PHP files on my server.

    I'm also not about to tell the people that I share my server with that they need to chmod ALL of their PHP files after uploading them. That is just ridiculous.

    As for the things that Vishal said to do, some are neccessary changes, some are temporary fixes that undo security checks to allow your users to send e-mail as nobody, which can make it hard for you to track down which users are sending spam mail from your server.

    To be quite honest with you if you have no knowledge in this area you shouldn't be hosting websites.

    If you're not a host however and just trying to save money running your own dedicated server though, that's a different story. In any story, you have to either read the book, or wait for it to come out on film if you're too lazy to read. ;)

    (what that means is you can either read the manuals and figure out how to fix it or wait for someone that has read the manuals to figure out how to fix it and share it with us, I wasn't saying that I knew the answer and wasn't sharing it with you)
     
    #9 rnh, Apr 17, 2003
    Last edited: Apr 17, 2003
  10. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Ye and? I mean what doesnt have bugs in it? cPanel is full of it. Does that stop you from running it?

    To each his own. I mean if you users are not willing to do as they are told then you have no business hosting them. IF they are running cgi they have to chmod their files to 755 anyway, dont they? So whats the extra step of remembering to chmod your php scripts to 755? Ever heard of fixing insecure permissions?
    What are you talking about? cPanel is allowing mail to be sent out as nobody, right now and always has, unless you install phpsuexec. This is what we are all talking about. Its got nothing to do with Vishal has done. He said he didnt install phpsuexec didnt he? Read the msg again.

    What does the rest of you message have anything to do with anything? I just dont get what your ranting about.
     
    #10 sexy_guy, Apr 17, 2003
    Last edited: Apr 17, 2003
  11. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    I'm not hosting anyone, I thought that I implied that with my message.

    I don't know about you but on my websites I have an average of 200 + PHP files on each website I run. If a host told me that I had to go through and Chmod them all I would tell them to F* off and get a new host as I have had quite a few hosts before I moved to my own dedicated servers and have never had to do this before. This is definitely not a common practice.

    Hence the reason I don't run CGI any more and switched to PHP.

    IT'S A PAIN THE BUTT.


    Ever heard of not being an @$$hole?


    NO. Cpanel is allowing mail to be sent out as nobody unless you check "Prevent the user 'nobody' from sending out mail to remote addresses"

    It is possible that certain variables such as php_admin_value sendmail_path can fix the problem of PHP sending e-mail as nobody without needing PHPSuExec. After all, this problem can be fixed on Ensim without the buggy PHPSuExec, so why not Cpanel?

    Look at the message above mine that I was responding to, before you get so sarcastic and rude.

    Caperman asked:
    Vishal said to do the following:

    Uncomment never_user = root (root cannot send mails).
    Set sender_verify to false, so that sender addresses are not verified.

    I would not make these changes if I was a host.

    I don't get why this has anything to do with you that you feel the need to try to start an argument with me.

    I have been reading through these forums for the last few days and have found your posts to be more of a nuisance than anything.

    My "rant" was about how "hosts" out there come in here not knowing DIDDLY SQUAT and expect THEIR COMPETITION to tell them how to fix their servers and don't even try to figure out things on their own. My problem with this is that if you have NO KNOWLEDGE of BASIC UNIX administration then you SHOULD NOT be hosting.

    This line made that quite clear and I have no idea what about it you didn't understand.

     
    #11 rnh, Apr 17, 2003
    Last edited: Apr 17, 2003
  12. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Likewise! Unless you know what your talking about dont try to act like you do. This is what you said;

    NO. Cpanel is allowing mail to be sent out as nobody unless you check "Prevent the user 'nobody' from sending out mail to remote addresses"

    To correct you once again, that is not the reason why email is being sent out as nobody at all. I have mine unchecked and mail is being sent out as nobody. Now that you know that you should be able to rest easy tonight.
     
  13. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    No offense, but do you have problems with the English language?



    Maybe you should try taking your own advice.

    I NEVER said that that was the reason that that e-mail was being sent out as nobody. It is being sent out as nobody because PHP is doing that.

    What I did say is that UNLESS you have that checked, Cpanel will allow e-mail to be sent as nobody. IF you have that checked CPanel supposedly does not let mail be sent as nobody.

    Wow. Good for you. I'm so proud of you.

    Now good luck finding out who sent out spam e-mails should one of your users send out spam from your server.
     
  14. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Yes, actually it does. I just installed Cpanel the night before last on a test server and I must say that I am VERY dissapointed with it.

    I really regret paying for my license and wish that I would have gotten a test license first as this is a very buggy control panel and is a total pain in the butt.

    Other than that, Cpanel is great.
     
  15. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    The question would be why can Ensim and Plesk do this without a problem? Why is cPanel such a problem? Forcing us to install phpsuexec then finding out that checking this option in tweeks still produces results such as UNROUTABLE DOMAIN and bounced msgs back to nobody is simply inexcusable. Even with phpsuexec installed and the option clicked does not fixed unroutable domain problems. :rolleyes:

    Email is the number one reason why my customers will cancel on me. When its flawed and non functional the TT's pile up with questions as to why their mail never got delivered here and there etc etc.

    Now if i look in WHM news i see this

    Unroutable Mail Domain Error If you are seeing this error when sending mail from php scripts you should disable the 'Prevent the user 'nobody' from sending out mail to remote addresses' option in tweak settings. Unless you have installed phpsuexec all php scripts will run as the user 'nobody'. Please note that this is nothing wrong with this feature, and it functions exactly as it is intented to. We have included this message because many people were unclear as to what this feature does.

    Now that i have phpsuexec installed i should be able to check the options right? Well sure i can check the option but now im seeing unroutable domain errors!

    :confused:
     
    #15 sexy_guy, Apr 17, 2003
    Last edited: Apr 17, 2003
  16. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    Yes, I'm very annoyed with Cpanel. I'm going to go check on my money back guaruntee options.
     
  17. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    2003-04-17 20:10:47 196KGJ-00058B-00 == nobody@powerservers.com T=local_delivery defer (13): Permission denied: failed to create directories for //mail: Permission denied ???
     
  18. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    rnh!!!

    Hello,

    rhn I think u haven't read my posting correctly... or may be u r not aware of exim.

    My configuration for exim.conf is

    I have ***UNCOMMENTED**
    never_user = root

    It means that root is not allowed to send mails OK!!!

    sender_verify = true

    (I just told them to try and use false there. I have a true value for sender_verify) ok )

    I was having the same error
    2003-04-16 03:26:28 195hJi-00052T-00 == nobody@c3.combuzz.org T=local_delivery defer (13): Permission denied: failed to create directories for //mail: Permission denied
    I checked off the "Prevent nobody" from twek settings and qualify_domain = validdomain.

    I told u my problem was that the hostname was not resolving and that is why the destination machine was rejecting my mailsso to make it work. I used qualify_domain.

    Regards,


    :confused:
     
  19. rnh

    rnh Well-Known Member

    Joined:
    Apr 15, 2003
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    16
    ah, sorry for the misunderstanding Vishal, thought that you were telling them to set those to false :)
     
  20. vishal

    vishal Well-Known Member

    Joined:
    Jan 28, 2003
    Messages:
    340
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    That's Really ok

    NO Problem !!!! :)

    Regards,
     
Loading...

Share This Page