Eyas Almamoun

Registered
Oct 25, 2018
1
0
1
Saudi
cPanel Access Level
Root Administrator
I'm trying to enable php extensions openssl, Tokenizer, ctype & JSON in a machine with WHM/Cpanel, however in EasyApache 4 which is up to date I can't see Exhaustive Options List.
Any ideas?
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,292
313
Houston
Hi @Eyas Almamoun

There is no exhaustive options list in EasyApache 4, you can install PHP extensions through the UI in EA4 or what you'd need to use is the Module Installers I'm assuming at WHM>>Software>>Module Installers
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,292
313
Houston
So after looking at those specific extensions if that's what you're looking for, each one of them should be built in to cpanel's PHP

Code:
 php -m |egrep -i 'tokenizer|openssl|ctype|json'
or you can view each PHP version with the following:

Code:
/opt/cpanel/ea-php73/root/bin/php -m |egrep -i 'tokenizer|openssl|ctype|json'
just change ea-php73 to the version you're looking for.