The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enabling suhosin function for one account dont works

Discussion in 'Security' started by postcd, May 7, 2014.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    619
    Likes Received:
    6
    Trophy Points:
    18
    Im solving this issue a few days already, would appreacieate if anyone can help

    have:
    PHP 5.3.28
    Apache/2.2.27
    CGI handler
    SuExec
    Suhosin

    i deleted disable_functions from php.ini and isntead used suhosin disabled fucntions. then i need to whitelist exec for one account.

    so i created folder structure to this:
    /usr/local/apache/conf/userdata/std/2_2/awzfsnat/mydomain.com/disabledfunctions.conf
    /usr/local/apache/conf/userdata/std/2/awzfsnat/mydomain.com/disabledfunctions.conf

    file contains:
    i tried various moddification to this, but none work to show "exec" function as whitelisted in php(info) (httpd restarted)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you elaborate on what specific entry you are expecting to see in the PHPINFO file? Is there a particular reason you prefer not to use the disable_functions option that comes standard with PHP?

    Thank you.
     
  3. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    619
    Likes Received:
    6
    Trophy Points:
    18
    suhosin.executor.func.whitelist
    because disable_functions disable globally, i need only one cpanel account to have exec function allowed. Tell how to do it if you know.
     
Loading...

Share This Page