Encoding Problem after moving Server

mahdy_sharifi

Well-Known Member
Feb 26, 2012
220
1
68
cPanel Access Level
Root Administrator
Hello :

I was moved my customer from old server to newserver with same PHP configuare , but some customer website encoding carecter show like ???? ! this Problem occur for template

I was moved my customer from old server to new server with same PHP configure , but some customer website encoding character show like ???? ! this Problem occur for user template only PHP-nuke template or Worpress , SQL not problem occur .
at least 100 website have this problem and i don't remember how can resolve Problem.

Can you Help ?

Regards
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello,

Do you have mbstring compiled into PHP on the new machine? This PHP module is required for several languages to work for PHP:

PHP: Introduction - Manual

You can check in root SSH if it is compiled with the following:

Code:
php -m | grep -i mbstring
If it is not compiled, simply run WHM > EasyApache (Apache Update) or /scripts/easyapache to add it in Step 6 Exhaustive Options List under PHP.

Thanks!
 

Gili-H

Member
Aug 24, 2011
16
0
51
cPanel Access Level
Root Administrator
Twitter
Hi,
If you want to use UTF-8 charsets in your php files change this values in your php.ini.
The easy way is:
WHM >> Main >> Service Configuration >> PHP Configuration Editor >> Advanced Mode
mbstring.func_overload = 0
mbstring.http_input = pass
mbstring.http_output = pass
mbstring.internal_encoding = "utf-8"
mbstring.language = Natural
mbstring.substitute_character = none
 

mahdy_sharifi

Well-Known Member
Feb 26, 2012
220
1
68
cPanel Access Level
Root Administrator
Hi,
If you want to use UTF-8 charsets in your php files change this values in your php.ini.
The easy way is:
WHM >> Main >> Service Configuration >> PHP Configuration Editor >> Advanced Mode
mbstring.func_overload = 0
mbstring.http_input = pass
mbstring.http_output = pass
mbstring.internal_encoding = "utf-8"
mbstring.language = Natural
mbstring.substitute_character = none
Thank you
but not worked !