Encrypted password for SMTP

sopya

Member
Apr 27, 2012
15
0
51
cPanel Access Level
Root Administrator
Hello All,

I am configuring thunderbird, I have enabled all the secure protocols from WHM > Mail Configuration

Now when I set SMTP server as following
Port: 465
Connection security: SSL/TSL
Authentication method: Encrypted password

I am getting following error message.

-------------
The SMTP server mail.domain.com does not seem to support encrypted passwords. If you just set up this account, please try changing to 'Normal password' as the 'Authentication method' in the 'Account Settings | Server settings'. If it used to work and now suddenly fails, please contact your email administrator or provider.
-------------

But when I set SMTP server as following
Port: 465
Connection security: SSL/TSL
Authentication method: Normal Password

It works without any issue.

I am using dovecot mail server. Does that mean cPanel/Dovecot does not support "Encrypted password
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
You are configuring SMTP settings in Thunderbird, but Dovecot serves POP3 & IMAP connections.

If you are using secure connection then it does not matter if the password is plain text, because the entire transmission is already encrypted.
 

sopya

Member
Apr 27, 2012
15
0
51
cPanel Access Level
Root Administrator
Thx,

Ok Dovecot is for POP3 and IMAP. But why cPanel/Exim does not work with following combination.

SMTP server settings.
Port: 465
Connection security: SSL/TSL
Authentication method: Encrypted password


And same settings works with Authentication method: Normal Password

cPanel people any suggestion from your side?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

You will need to select "Normal Password" in your email client. Here is a snippet from a ticket that was opened for this a few weeks ago:

By tunneling over SSL/TLS, with a valid CA-signed certificate being used and a secure cypher selected, what is passed between the client and server is effectively cyphertext, as the plaintext of the password is tunneled within. Additionally, because of the use of SSL/TLS, the client can reasonably believe that it is talking to the correct server; that is, the client can authenticate the server, as well as the server authenticate the client. In this way, both transport and storage are encrypted and well protected.

Thank you.
 

sopya

Member
Apr 27, 2012
15
0
51
cPanel Access Level
Root Administrator
Hello :)

You will need to select "Normal Password" in your email client. Here is a snippet from a ticket that was opened for this a few weeks ago:

By tunneling over SSL/TLS, with a valid CA-signed certificate being used and a secure cypher selected, what is passed between the client and server is effectively cyphertext, as the plaintext of the password is tunneled within. Additionally, because of the use of SSL/TLS, the client can reasonably believe that it is talking to the correct server; that is, the client can authenticate the server, as well as the server authenticate the client. In this way, both transport and storage are encrypted and well protected.

Thank you.
Yes, as I said in my first post "Normal Password" is working. So thats not the issue, my only concern why 'encrypted password' not working with cPanel/Exim? Can we enable it? As I have checked and there is no option in Exim/cPanel configuration regarding 'encrypted password' for SMTP. Hope I am clear now.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Yes, you must select "Normal Password". Selecting "Encrypted Password" is not supported and will fail. Authentication will still be encrypted as long as you keep the "SSL/TLS" option enabled in your email client.

Thank you.