The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enom SSL Module issues

Discussion in 'Security' started by logicp, Jun 8, 2016.

  1. logicp

    logicp Registered

    Joined:
    Jun 8, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ottawa, Ontario
    cPanel Access Level:
    Root Administrator
    I have recently acquired a company with CPanel servers and clients who need to purchase SSL certificates. These certificates are purchased through CPanel product orders. These are done using the eNom SSL Certificates module.

    I have an eNom account and have put the appropriate credentials in the configuration. My eNom account has more than enough balance to make purchases on behalf of clients.

    Each time I make a purchase, the order appears in the client's Cpanel. Upon receiving payment, I manually change the status of the order to "Active", and a "Configure Now" link appears on the Product Details page.

    PROBLEMS:

    1. The SSL Provisioning Date is 0000-00-00
    2. Clicking this link sends you to a page that says "Invalid Link Followed. Please go back and try again."
    3. Logging into eNom, and investigating my order history, yields a result of no orders having been made for any SSL certificates.


    MY QUESTION:

    How is it possible that the product details would receive a "configure now" link for a certificate if the system has not verified that such a certificate even exists? Am I missing a step in this process?

    Has anyone ever seen similar behaviour? I would be very grateful for any suggestions or resources.

    Thank you.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you let us know the specific steps, including the specific options in Web Host Manager, we can use to reproduce this issue?

    Thank you.
     
Loading...

Share This Page