The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Entropy banner don't work ?

Discussion in 'General Discussion' started by speckados, Aug 17, 2003.

  1. speckados

    speckados Well-Known Member

    Joined:
    May 21, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Acequias :: Granada :: España
    cPanel Access Level:
    DataCenter Provider
    Twitter:
    After upgrade, Entropy banner don't work. On test page with HTM Tags and on body <!--#exec cmd="/usr/local/cpanel/cgi-sys/entropybanner.cgi user"-->, and saved how .shtml, the page show a blank page.

    Any ideas?

    cPanel.net Support Ticket Number:
     
  2. RedFutura

    RedFutura Well-Known Member

    Joined:
    Jun 11, 2003
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    same here!

    cPanel.net Support Ticket Number:
     
  3. Damian

    Damian Well-Known Member

    Joined:
    Oct 1, 2001
    Messages:
    95
    Likes Received:
    1
    Trophy Points:
    8
    The link should read:

    cgi-bin/entropybanner.cgi

    *Note that there is no need to specify the 'user' as a parameter.

    If you are not using the XSkin supplied by Cpanel the text in your skin may be out of date. Check with the skin author.

    cPanel.net Support Ticket Number:
     
  4. Doctor

    Doctor Well-Known Member

    Joined:
    Apr 26, 2003
    Messages:
    180
    Likes Received:
    0
    Trophy Points:
    16
    Just do the following:

    cd /home/username/public_html/cgi-bin

    cp /usr/local/cpanel/cgi-sys/entropybanner.cgi entropybanner.cgi

    Then, use <!--#exec cmd="cgi-bin/entropybanner.cgi"--> in your .shtml pages that you want the banner to display.

    The problem is after the upgrade, CPanel no longer copies entropybanner.cgi to the user's cgi-bin. And because of suexec, calling entropybanner.cgi from /usr/local/cpanel/cgi-sys/ won't work. The same solution should apply to randhtml.cgi if any of you happens to have a problem displaying your random codes.
     
Loading...

Share This Page