The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Envelope-to changes in cPanel 58

Discussion in 'Workarounds and Optimization' started by gizzmo2006, Aug 24, 2016.

Tags:
  1. gizzmo2006

    gizzmo2006 Active Member

    Joined:
    May 22, 2007
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    Hello,
    after the update to 11.58.20 there are more than one mailadresses in the envelope-to field when a mail was sent to more than one recipient at the same domain.
    Looks like this:
    Return-path: <cxxxxxxxx@gmail.com>
    Envelope-to: ixxxxx@xxxxxxxng.de,
    vxxxxxxxx@xxxxxxxxng.de

    But Tobit can work only with one mailadress in the Envelope-to Field. If there are more than one ardesses in this field, every user will get the same mail multiple times.

    Any idea, how i can fix this?

    Regards Frank
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. gizzmo2006

    gizzmo2006 Active Member

    Joined:
    May 22, 2007
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    Hello Michael,

    thank you for Response. But sorry, this is not correct. I`m running build 11.24.
    If there are more than one recipient at the same Domain, the envelope-to: Field will look exact like this:

    Envelope-to: ixxxxx@xxxxxxxng.de,
    vxxxxxxxx@xxxxxxxxng.de

    Tobit can not work with this. Every recipient in the envelope-to: Field will get as much copies of the mail as there
    will be envelope-to: adresses filed in...

    Regards Frank
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you verify if the application sends out emails using the "BCC" or "CC" fields, or if it just includes all recipients in the "To" field?

    Thank you.
     
  5. gizzmo2006

    gizzmo2006 Active Member

    Joined:
    May 22, 2007
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    Hello Michael,

    i tried both. With BCC only one adress is in envelope-to field. With CC all adresses from CC will be in envelope-to field.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's by design that email addresses added to the "CC" line of the email are included on the "Envelope-To" line in the message header. Splitting the deliveries for each email address into separate LMTP transactions would result in a performance loss. This is further explained on the following Exim Users thread:

    why multiple recipients in Envelope-To header? | exim | users

    You could disable the envelope_to_add directive in the Exim configuration, however that would break email filtering. I reccomend reaching out to the developers of the script you are using to see if there are any options available to use "BCC" instead of "CC" for these emails.

    Thank you.
     
  7. gizzmo2006

    gizzmo2006 Active Member

    Joined:
    May 22, 2007
    Messages:
    36
    Likes Received:
    1
    Trophy Points:
    8
    Hello Michael,

    with envelope-to disabled, Tobit can not work with.. I can send in BCC with my Clients. But i can not do it on every mail client all over the world.. This is are no Solutions to fix the problem..

    In earlier Versions of exim this has all been single Transactions and i never had Performance Problems.

    I found a batch_max Setting in exim.conf:

    batch_max = 200

    Is there a way to modify exim to work without Batch? I have set it to 1, but no changes?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,830
    Likes Received:
    672
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Here are the relevant entries in the /etc/exim.conf file:

    Code:
    dovecot_delivery:
      driver = lmtp
      socket = /var/run/dovecot/lmtp
      batch_max = 200
      rcpt_include_affixes
      delivery_date_add
      envelope_to_add
      return_path_add
    
    dovecot_virtual_delivery:
      driver = lmtp
      socket = /var/run/dovecot/lmtp
      batch_max = 200
      rcpt_include_affixes
      delivery_date_add
      envelope_to_add
      return_path_add
    Could you let us know what method you used to modify the batch_max value? Did you restart Exim after making the changes?

    Thank you.
     

Share This Page