Erro in Install (Bad file descriptor at ./install line 650)

CleberDantas

Registered
Jul 16, 2006
4
0
151
Hello,

I have erro in install in VPS witch centos4 and centos5.

What problem?


...............open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
.open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
[[email protected] home]#
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,483
35
208
cPanel Access Level
DataCenter Provider
Hello,

I have erro in install in VPS witch centos4 and centos5.

What problem?


...............open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
.open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
[[email protected] home]#
Could you paste the reset of the output ?

Its kinda hard to guess where it failed without the #s and x markers.

Thanks!
 

CleberDantas

Registered
Jul 16, 2006
4
0
151
.x12...13...14..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
.open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650
[[email protected] home]#

I tested in vps witch centos4 and centos5 ;
 

markhard

Well-Known Member
Apr 22, 2004
252
0
166
on my vps it stop after x11..12...open3: close(main::RNULL) failed: Bad file descriptor at ./install line 650

and then the install stop.

using Centos 4.4 on the VPS, how to solve this problem? does it will affect on cpanel runtime?
 

markhard

Well-Known Member
Apr 22, 2004
252
0
166
nick, what information do you need? currently i'm trying to run the installer script again, it seems that i can go through .x11..12... but i don't know whether it's good installation.

any way on the first install, it stop after .x11..12... and on /var/log/cpanel-install-thread1.log i see

Code:
pty_allocate(nonfatal): getpt(): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
pty_allocate(nonfatal): openpty(): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
pty_allocate(nonfatal): open(/dev/ptmx): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
Cannot open a pty at /scripts/cPScript/cPCPAN.pm line 207
Method: Perl Expect
STARTING RPMUP
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No Packages marked for Update/Obsoletion
FINISHED RPMUP
 

markhard

Well-Known Member
Apr 22, 2004
252
0
166
running installer 2nd time seems finished the installation, however i got several errors, here are some:

Code:
Waiting for whostmgrd to shutdown......Done
(internal death while parsing ) Mon Aug  6 18:10:12 2007 [10228] error: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/lib/perl /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/cpanellogd line 62.
 at /usr/local/cpanel/cpanellogd line 62
        main::BEGIN() called at DBD/mysql.pm line 62
        eval {...} called at DBD/mysql.pm line 62


(internal death while parsing ) Mon Aug  6 18:10:12 2007 [10228] error: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/lib/perl /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/cpanellogd line 62.
BEGIN failed--compilation aborted at /usr/local/cpanel/cpanellogd line 62.
 at /usr/local/cpanel/cpanellogd line 62


Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/lib/perl /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/local/cpanel/cpanellogd line 62.
BEGIN failed--compilation aborted at /usr/local/cpanel/cpanellogd line 62.
[a fatal error or timeout occurred while processing this directive][a fatal error or timeout occurred while processing this directive]Waiting for cppop to shutdown......Done
Waiting for cppop-ssl to shutdown......Done
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/local/cpanel /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at (eval 3) line 3.
Perhaps the DBD::mysql perl module hasn't been fully installed,
or perhaps the capitalisation of 'mysql' isn't right.
Available drivers: DBM, ExampleP, File, Gofer, Proxy, Sponge.
 at /usr/local/cpanel/bin/eximstats line 236
when i try to login to SSH got this error:

Code:
Server refused to allocate pty
what went wrong?
 

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,483
35
208
cPanel Access Level
DataCenter Provider
nick, what information do you need? currently i'm trying to run the installer script again, it seems that i can go through .x11..12... but i don't know whether it's good installation.

any way on the first install, it stop after .x11..12... and on /var/log/cpanel-install-thread1.log i see

Code:
pty_allocate(nonfatal): getpt(): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
pty_allocate(nonfatal): openpty(): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
pty_allocate(nonfatal): open(/dev/ptmx): No such file or directory at /usr/lib/perl5/site_perl/5.8.8/i686-linux/IO/Pty.pm line 24.
Cannot open a pty at /scripts/cPScript/cPCPAN.pm line 207
Method: Perl Expect
STARTING RPMUP
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No Packages marked for Update/Obsoletion
FINISHED RPMUP
Is this on virtuozzo ?

If so wipe the ve and start again. This time make sure /dev/urandom and /dev/ptmx are there as the install will fail otherwise.
 

markhard

Well-Known Member
Apr 22, 2004
252
0
166
how to fix "error: Can't locate DBD/mysql.pm in @INC" manually without re-installing cpanel?