Error accessing WordPress MYSQL database during install with CPAddons

fennelly1983

Registered
May 23, 2011
2
0
51
Adam Fennelly - 20 May 11 5:27:16 PM


I am having a strange issue when trying to install WordPress through CPanel and CPAddons. Here is essentially what is happening:

I submit the request using Site Software in CPanel on the account I am trying to install WordPress on. In WHM I attempt to accept the request like I always do but then get the following error:

You do not have access to that database (signat_wp1)!

When I go look at my tables for that account, I notice that instead of creating a database and user of signat_wp1, it created root_signat_wp1 instead.

I have tried updating WHM to see if it fixed the issued which it didn't, reinstalled the latest WordPress CPanel addon, and are still experiencing the same issue. Do you have any ideas/suggestions for how I can fix this issue?

Ive searched everywhere and cant seem to find a solution on this, the only relevant post I came across was someone with the same issue but had no informative replies.
I would just disable moderation for the CpAddon for WordPress but there doesn't seem to be an option for this.
I've tried forcing a reinstall of cPanel and re-mapping databases but had no such joy. If anyone has any ideas I would be very appreciative.

Thank you.
 
Last edited:

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
What is your cPanel version on the machine?

Code:
cat /usr/local/cpanel/version
Next, you can disable moderation by unchecking any cPAddons in WHM > Manage cPAddons area that have a check in the "cPAddon Moderation Configuration" box next to the cPAddon name, then clicking the "Update Moderation" button.
 

fennelly1983

Registered
May 23, 2011
2
0
51
What is your cPanel version on the machine?

Code:
cat /usr/local/cpanel/version
Next, you can disable moderation by unchecking any cPAddons in WHM > Manage cPAddons area that have a check in the "cPAddon Moderation Configuration" box next to the cPAddon name, then clicking the "Update Moderation" button.
Thanks cPanelTristan,
The version is 11.28.87, will try disabling the moderation and see how that goes..