The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error adding user to database

Discussion in 'Database Discussions' started by Jo Travers, Nov 30, 2016.

Tags:
  1. Jo Travers

    Jo Travers Registered

    Joined:
    Nov 30, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Preston
    cPanel Access Level:
    Root Administrator
    When try to add a user to a mysql database I get the following error:

    There was a problem adding the user: (XID gczus2) Database Error: Can't find any matching row in the user table

    Any ideas?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Jo Travers,

    Check to see if skip-name-resolve is enabled in your /etc/my.cnf file on this system. If so, disable or remove the entry, and then restart MySQL via the "/scripts/restartsrv_mysql" command. cPanel isn't designed or tested with the skip-name-resolve option in the /etc/my.cnf , and it can break certain functionality.

    Thanks!
     
    rakeshyeole likes this.
  3. Sterlingz

    Sterlingz Registered

    Joined:
    Dec 24, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    OP did you try this?

    Having the same problem.

    And there's no my.cnf file in that folder for me.

    I'm a total noob mind you.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,171
    Likes Received:
    1,295
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Check to ensure you are logged in as "root" via SSH. It's the root /etc directory, as opposed to /home/$username/etc.

    Thanks!
     
Loading...

Share This Page