error "Can't locate Cpanel/Version.pm in"

drako

Member
Dec 30, 2013
13
0
1
cPanel Access Level
Website Owner
Hello,

i have a bash script that calls a perl file.

i get the error below

Code:
Can't locate Cpanel/Version.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/x86_64-linux 

/usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux 

/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at ./install.pl line 3.
BEGIN failed--compilation aborted at ./install.pl line 3.
The file install.pl

Code:
#!/usr/local/cpanel/3rdparty/bin/perl

use Cpanel::Version ();
 

drako

Member
Dec 30, 2013
13
0
1
cPanel Access Level
Website Owner
Hello Michael,

i am sorry i am starting new with both perl and whm plugin development.
i read through the link you sent but still am stuck.

i have whm version WHM 11.42.1 (build 13), am i pointing to the wrong perl in my file? i did change it to /usr/bin/perl but it didn't work either.

i am developing a WHM Plugin.

Appreciate your support.