The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error: client denied...

Discussion in 'General Discussion' started by twarlock, Sep 1, 2004.

  1. twarlock

    twarlock Member

    Joined:
    Feb 12, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Everything was working fine but now I get this error on all domains on my server:

    [Wed Sep 1 07:02:55 2004] [error] [client XXX.XXX.XXX.XXX] client denied by server configuration: /home/XXXXXX/public_html/index.html

    index.html is there.
    index.php is working.

    I have checked httpd.conf and index.html is set as default page. Actally I get "Forbidden" when trying to access any html file. All are CHMOD 644.

    public_html is CHMOD 750 (751, 755 are not working eather).

    /scripts/enablefileprotect solved nothing

    apache bouilt wth "Prevent Users from reading other webroots"
    user dir is set to user:nobody

    running:
    WHM 9.4.0 cPanel 9.4.1-R64
    RedHat 9 - WHM X v3.1.0

    Thanks
     
    #1 twarlock, Sep 1, 2004
    Last edited: Sep 1, 2004
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Just reread and saw that what I suggested, you've already tried :(
     
  3. twarlock

    twarlock Member

    Joined:
    Feb 12, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    So... no ideas? :confused:
     
  4. bigpy2003

    bigpy2003 Well-Known Member

    Joined:
    Feb 22, 2004
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Maybe check and make sure that the current user is executing the script?

    Example:
    domain.com

    user: domain

    then in ssh goto:
    cd /home/domain/public_html

    type:
    ls -al

    If it says 'root', well you need to change your owner of all the files in that dir.

    This is how:

    chgrp -R domain:domain *

    This will set the owner and group for every file in that dir. You can only do this as root.
     
  5. twarlock

    twarlock Member

    Joined:
    Feb 12, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thanks for you suggestion but the owner of every file is user.
     
  6. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    *.html forbidden

    I also got error similar above. Anybody knows how to fix the problem ? WHM 10.1.0 cPanel 10.2.0-S83, Redhat 9

    cPanel tickets ID# 101704
     
    #6 erwinfa, Jun 7, 2005
    Last edited: Jun 7, 2005
  7. bijo

    bijo Well-Known Member

    Joined:
    Aug 21, 2004
    Messages:
    475
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Hello,

    Did you enable the mod_dosevasive module in your apache config? If yes disable it. And also check the permission of the file.
    May be it will help you to solve this issue.
    Let me know the status.
     
    #7 bijo, Jun 7, 2005
    Last edited: Jun 8, 2005
  8. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    No, I dont use mod_dosevasive

    Here're the loaded modules :
    mod_security, mod_auth_passthrough, mod_log_bytes, mod_bwlimited, mod_php4, mod_frontpage, mod_setenvif, mod_so, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_status, mod_negotiation, mod_mime, mod_log_config, mod_env, http_core

    Any other solutions ?
     
  9. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    This error could be one of two things:
    .htaccess is not configured properly by this client
    or
    PARSING feeds: you need to double check and see if the codes in the *.php and *.html are correct.
     
  10. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    All *.php file can be accessed fine. Only *.html can't be accesed and got error Forbidden...

    And this is happened to all accounts using *.html, I have tried to remove .htaccess, but still got the same error message :mad:
     
  11. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    vi /etc/httpd/conf/httpd.conf

    Make sure you have this syntax uncommented:

    Code:
    <IfModule mod_dir.c>
    DirectoryIndex index.html index.wml index.cgi index.shtml index.jsp index.js index.jp index.php4 index.php3 index.php index.phtml index.htm default.htm default.html home.htm
    </IfModule>
    and

    Code:
    Options Indexes FollowSymLinks MultiViews
    Overall, double check on your httpd.conf and make sure the entries are correct or messed up.
     
  12. erwinfa

    erwinfa Well-Known Member

    Joined:
    Jun 14, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    0
    Yes sure,

    These setting were there ...

     
  13. sumith

    sumith Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    96
    Likes Received:
    2
    Trophy Points:
    8
    Hello,

    Seems it has some relation with mod_security. Can you disable it and try the same? If it doesn't helps, paste the httpd.conf file here to have a detailed check.
     
  14. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    Same problem. All suggestions on this thread are as suggested. What else to try? I have not touched my .htaccess in years, and it was working!
     
Loading...

Share This Page