The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error code: ssl_error_rx_record_too_long

Discussion in 'General Discussion' started by matins007, Jan 29, 2009.

  1. matins007

    matins007 Member

    Joined:
    Jan 15, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I get this error when accessing my site in https.

    Ayy idea what could cause this, thanks.

    M.
     
  2. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    There could be a few reasons for this, including:

    - Your Apache server isn't started with SSL support (Try /scripts/restartsrv_apache).
    - You're using a non-shared SSL certificate on a shared IP host. You'll need to move the host to a dedicated IP in this case.
    - Your certificate or key is invalid. Verify it is set up properly in WHM, or try re-installing it. Sometimes this means removing all previous versions of the certificate manually in either /etc/ssl or /usr/share/ssl.

    There are other reasons, but those are what I can think of off the top of my head!
     
  3. matins007

    matins007 Member

    Joined:
    Jan 15, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply,

    I know it's not the 2 first options, already checked those.

    Any idea what to look for (and where) the verify if the SSL is set up right?

    -I've already checked that the HTTPS listen port is 443.
    -The certificate show up good in WHM, with it's own IP.

    Thanks for your help
     
Loading...

Share This Page