The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error compiling chkrootkit

Discussion in 'General Discussion' started by sexy_guy, Apr 18, 2003.

  1. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    Very strange. I cant seem to be able to compile the new version of chkrootkit-0.40. Everytime i do i get somkind of weird error.

    root@srv1 [/usr/local/chkrootkit-0.40]# make sense
    gcc -DHAVE_LASTLOG_H -o ifpromisc ifpromisc.c
    In file included from /usr/include/linux/if.h:22,
    from ifpromisc.c:28:
    /usr/include/linux/types.h:124: parse error before `__kernel_daddr_t'
    /usr/include/linux/types.h:124: warning: no semicolon at end of struct or union
    /usr/include/linux/types.h:125: warning: data definition has no type or storage class
    /usr/include/linux/types.h:128: parse error before `}'
    make: *** [ifpromisc] Error 1
    root@srv01 [/usr/local/chkrootkit-0.40]#

    I looked at the source to see if something was amuck and nothing. The source is identical to the source on my other boxes which were not a problem, if.h matches the other boxes. Types.h is also fine. Im wondering about the easyapache build i installed from 2 nights ago.

    There is something wrong with this build. It also did not compile my MySQL 4.0 libs like it should have, phpinfo says its back at the 3.29 client and phpsuexec seems to be a problem since im still seeing nobody@mydomain sending email. Now this!!
     
  2. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    The chkrootkit error has nothing to do with cPanel or buildapache -- I get the same error on non cPanel boxes.
     
  3. sexy_guy

    sexy_guy Well-Known Member

    Joined:
    Mar 19, 2003
    Messages:
    848
    Likes Received:
    0
    Trophy Points:
    16
    I didnt say it did, did i?
     
  4. bmcpanel

    bmcpanel Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    546
    Likes Received:
    0
    Trophy Points:
    16
    I read something somewhere about this new version having an installation problem such as the one you are experiencing (The newer version of CHKROOTKIT). I forget what causes the install error, but it seems to be a known issue.

    I suggest going to your favorite search engine and searching for "chkrootkit install" or something like that. You may be able to dig up the info I am referring to.
     
  5. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Sexy guy, could it be that in WHM / tweak settings you don't have MySQL 4 selected?

    If not, select MySQL 4 and after that rebuild apache.

    I hope that helps. :)
     
  6. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    You implied it by posting on a CPANEL SUPPORT FORUM.
     
  7. X-Istencedotcom

    X-Istencedotcom Well-Known Member

    Joined:
    Apr 14, 2003
    Messages:
    223
    Likes Received:
    0
    Trophy Points:
    16
    why is it that on Linux i used to always get compile errors, i am on FreeBSD, and using the ports tree i installed chkrootkit within seconds and it has no compile errors at all.
     
  8. mitul

    mitul Well-Known Member

    Joined:
    Feb 8, 2003
    Messages:
    291
    Likes Received:
    0
    Trophy Points:
    16
    I was able to compile latest version on RH 7.2, but fired up same error on RH 7.3. So I transfered the files compile on RH 7.2 to RH 7.3 and then it worked fine.
     
Loading...

Share This Page