The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error con RubyGems

Discussion in 'Discusión en Español' started by Javi124, Apr 22, 2016.

Tags:
  1. Javi124

    Javi124 Registered

    Joined:
    Apr 22, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    SPAIN
    cPanel Access Level:
    Root Administrator
    Hola a todos, es mi primer post y es acerca de un error del que no encuentro solución y por el que mi proyecto se encuentra parado, os lo voy a explicar a ver si alguno habeís estado en la misma situación y me podéis ayudar.
    Al intentar instalar gemas desde el software RubiGems instalado en cPanel siempre obtengo el mismo error:
    ERROR: While executing gem ... (OptionParser::InvalidOption) invalid option: -y
    Es un error referente a la versión instalada en el servidor 1.8.7, del cual, despues de cuatro días, mi hosting no ha sabido solucionar. Yo he intentado solucionarlo actualizando la versión, pero obtengo el mismo error, y a través de SSH da error en el directorio raíz (al que no tengo acceso) de un archivo protegido contra escritura. El servicio técnico de mi hosting me dice que es un problema a nivel mundial de cPanel, y no me dan fecha de solución. ¿Alguien se ha encontrado en esta situación? ¿alguna idea que me ayude a prosperar en mi proyecto?
    Gracias.
    Saludos.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you verify which operating system is installed on this server? We do not currently support Ruby installations on CentOS 7, CloudLinux 7, or RHEL 7:

    Guide to Ruby Installations - Requirements - cPanel Knowledge Base - cPanel Documentation

    Also, do you have root access to this system, or a hosting account with your web hosting provider?

    Thank you.

    Translation:

    Hola :)

    Podría usted comprobar qué sistema operativo está instalado en este servidor? Actualmente, no admite las instalaciones de rubíes en CentOS 7, CloudLinux 7, o RHEL 7:

    Guide to Ruby Installations - Requirements - cPanel Knowledge Base - cPanel Documentation

    Además, tienes acceso root a este sistema, o una cuenta de alojamiento con su proveedor de alojamiento web?

    Gracias.
     
  3. Javi124

    Javi124 Registered

    Joined:
    Apr 22, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    SPAIN
    cPanel Access Level:
    Root Administrator
    El problema ya esta localizado, no tengo acceso root, y tienen que hacer pruebas para que otros usuarios (es un host compartido) no se vean afectados con la actualización. Me toca esperar o cambiar de tipo de servicio a VPS, pero estamos empezando con el proyecto... y todos los inicios son difíciles, osea a esperar a ver si pueden actualizar :(.
    Muchas gracias por tu interés y respuesta.
    Saludos.
     
  4. Javi124

    Javi124 Registered

    Joined:
    Apr 22, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    SPAIN
    cPanel Access Level:
    Root Administrator
    Hola, gracias por tu interés, pero creo que no me has entendido. No tenemos VPS, esa es la opción que me dice mi hosting, que cambie mi plan actual, que es shared hosting, por VPS, porque el tema de actualizar Ruby les debe estar dando algún quebradero de cabeza, y en VPS lo puedo actualizar yo directamente, sin afectar o otros usuarios.
    Pero claro, el precio se dispara, y como he comentado, estamos empezando y primero queremos empezar y valorar nuestras necesidades.
    Gracias de todos modos.
    Por cierto, no habÍa contestado aCpanelMichael, el servidor trabaja en Linux, y la version de cPanel es 11.52.4 (build 2).
    Saludos.
     
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Soliciting / promoting on these forums is not permitted. Posts removed.
     
Loading...

Share This Page