Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error downloading packages EA4-experimental

Discussion in 'EasyApache' started by toffe, Jan 26, 2018.

  1. toffe

    toffe Active Member

    Joined:
    Oct 3, 2017
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    When I´m trying to install and uninstall an apache module, the EA4 forces me to update nghttp2 and libnghttp2, but they cannot be updated, it responds to eighter error 404 not found or connection timed out. Any ideas?

    Error: Error Downloading Packages:
    ea-nghttp2-1.20.0-.3.2.cpanel.x86_64: failure: x86_64/Packages/ea-nghttp2-1.20.0-.3.2.cpanel.x86_64.rpm from EA4-experimental: [Errno 256] No more mirrors to try.
    ea-libnghttp2-1.20.0-.3.2.cpanel.x86_64: failure: x86_64/Packages/ea-libnghttp2-1.20.0-.3.2.cpanel.x86_64.rpm from EA4-experimental: [Errno 256] No more mirrors to try.
    The entire output was logged to: /usr/local/cpanel/logs/packman/errors/2018-01-26_12:31:12-1

    Provision process finished.
     
  2. toffe

    toffe Active Member

    Joined:
    Oct 3, 2017
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    I´m really stuck, I need to uninstall a apache module and install another one, but it won´t let me because the update fails. Anyone?
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,071
    Likes Received:
    348
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. toffe

    toffe Active Member

    Joined:
    Oct 3, 2017
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
  5. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,071
    Likes Received:
    348
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Which module exactly?
     
  6. toffe

    toffe Active Member

    Joined:
    Oct 3, 2017
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Here is a screenshot. It get´s an error on the updates.
     

    Attached Files:

  7. toffe

    toffe Active Member

    Joined:
    Oct 3, 2017
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Ok I did "yum remove ea-apache24-mod_ruid2" then "yum install ea-apache24-mod_fcgid" but the upgrades are still there, Can I fix it?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,782
    Likes Received:
    1,712
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @toffe,

    It looks like you are actually encountering a defect with the EA4 mirrors. Internal case EA-7162 is open to address an issue where the ea-libnghttp2/ea-nghttp2 packages in the EA4 experimental repo have priority over the production packages in the EasyApache 4 mirrors due to an incorrect release number. I'll monitor this case and update this thread again once it's closed.

    Thank you.
     
  9. quarterstaff

    quarterstaff Member

    Joined:
    Feb 23, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    Hi Michael.
    Any update on this?

    Thanks.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,782
    Likes Received:
    1,712
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The RPMs in-question should no longer come from the EA4 experimental repo when updating. Try running the following command and let us know of any additional issues:

    Code:
     yum reinstall ea-nghttp2 ea-libnghttp2
    Thank you.
     
Loading...

Share This Page