Error during Full cPanel backup over FTP

jrianto

Active Member
Jun 9, 2008
44
0
56
Hi,
We have a client using our service for full cPanel backup. During the FTP transfer from their cPanel server to our FTP server, we see these error on the log:

Net::FTP=GLOB(0x1cc57a0)<<< 227 Entering Passive Mode (184,169,132,41,153,26)
Net::FTP=GLOB(0x1cc57a0)>>> STOR backup-6.23.2013_18-44-08_cpuser.tar.gz
Can't use an undefined value as a symbol reference at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/Net/FTP/dataconn.pm line 54.

What does that mean and how can we avoid or fix this error?

Thank you for your help!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

Please check to ensure there are no firewall rules on the cPanel server or the remote FTP server that could be blocking the FTP traffic.

Thank you.
 

ColinR

Registered
Jul 24, 2013
1
0
1
cPanel Access Level
Website Owner
Was your problem resolved? I am sitting with the same error.

Please check to ensure there are no firewall rules on the cPanel server or the remote FTP server that could be blocking the FTP traffic.
I have confirmed that no firewall rules are in place, and have confirmed that all is in order by copying files to the ftp server in passive mode.

Net::FTP=GLOB(0xe9dda60)<<< 200 ALLO OK. 613019844608 bytes available on "/backup/".
Net::FTP=GLOB(0xe9dda60)>>> PASV
Net::FTP=GLOB(0xe9dda60)<<< 227 Entering Passive Mode (111,222,333,44,19,145)
Net::FTP=GLOB(0xe9dda60)>>> STOR backup-7.25.2013_00-00-15_aaaaa.tar.gz
Can't use an undefined value as a symbol reference at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/Net/FTP/dataconn.pm line 54.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
I have confirmed that no firewall rules are in place, and have confirmed that all is in order by copying files to the ftp server in passive mode.
Have you checked the firewall rules on both the local server and the remote FTP server? If the issue persists, feel free to open a support ticket so we can take a closer look:

Submit A Ticket

You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

kpmedia

Well-Known Member
Feb 13, 2011
87
1
56
USA, Europe
cPanel Access Level
Root Administrator
I'm curious what host (if not your own server) gives this error.

I've run into it at the EIG-owned seohosting.com. It can login in to my server, so NOT a firewall issue, as it creates a blank tar.gz backup file. Their server aborts and disconnects soon thereafter. I've migrated many sites before, and this is the first time I've seen this.

As far as I'm concerned, it's just one more reason that EIG sucks (Hostgator, Bluehost, JustHost, iPage, etc).
 

PCZero

Well-Known Member
Dec 13, 2003
695
85
178
Earth
Michael we are having this exact same error. In our situation backups worked perfectly until we got a new IP issued to us by our ISP on the remote machine. After editing the remote backup parameters to use the new IP, we get this "Can't use an undefined value as a symbol reference at /usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/Net/FTP/dataconn.pm line 54"error when trying to validate the remote backup.

- - - Updated - - -

LOL Like a DFU I was doing something stupid and figured it out seconds after making my previous post. We use FireZilla Server as out rempte FTP agent. In the settings, there is a parameter for Passive Mode Settings. Rather than use the automatic "Retreive external IP from" setting, we had hard code the external Ip to use. DOH! When we changed the setting to the auto setting all worked well. Perhaps this will assist the other user.