Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Error: Email delivered on default account

Discussion in 'E-mail Discussion' started by Alessandro Ferrara, Feb 14, 2017.

  1. Alessandro Ferrara

    Joined:
    Feb 14, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Italy
    cPanel Access Level:
    Root Administrator
    Hello guys I'm new on this forum and I write you because I can not find a solution to my problem.

    I just bought a new dedicated server and I set as hostname srv1.domain.tld, I created an account with domain.tld domain and also an email address info@domain.tld.

    The info@domain.tld account is able to send emails but not receive them. Every email sent to info@domain.tld is delivered in the default email and not in info@domain.tld

    It could be a problem related to dns?
    Or maybe because domain.tld is the host domain?

    I tried many ways but no one work
    Can you give me some advice?

    The server has a centos 7_x64 and the latest version of cpanel, bind for dns, exim and dovecot!


    Thank you in advanc for help me
     
    #1 Alessandro Ferrara, Feb 14, 2017
    Last edited by a moderator: Feb 14, 2017
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,896
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you search for one of the affected messages in /var/log/exim_mainlog and let us know the output? EX:

    Code:
    exigrep user@domain.tld /var/log/exim_mainlog
    Post the output in CODE tags, and ensure to replace real domain names, hostnames, and IP addresses with examples.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Alessandro Ferrara

    Joined:
    Feb 14, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Italy
    cPanel Access Level:
    Root Administrator
    This is the log

    Code:
    Removed - Please post just one example from the output, and ensure to not post real domain names.
    
    Dovecot delivery to f3biz@srv1.domain.tld is right?
    Did I get it right?
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,896
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Check to see if one of the users on the system owns the server's hostname with a command such as:

    Code:
    /scripts/whoowns serv1.host.tld
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Alessandro Ferrara

    Joined:
    Feb 14, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Italy
    cPanel Access Level:
    Root Administrator
    Yes, nobody for example.com

    - Removed Please Attach Images to Your Posts -
     
  6. Alessandro Ferrara

    Joined:
    Feb 14, 2017
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Italy
    cPanel Access Level:
    Root Administrator
    Yes, nobody for example.com

    In the exim log Iread this:

    domain <info@domain.tld> R=localuser T=dovecot_delivery C="250 2.0.0 <f3biz@srv1.domain.tld> ICkYN1FRolgMEgAA1Tt8Zg Saved"

    So, the email is delivered on the default email, but not is like this defaultuser@domain.tld but is like this defaultuser@hostname.tld

    Why that?
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,802
    Likes Received:
    1,896
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look to see what's happening? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice