Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Error: Failed to detect code in SYSLOG_LOG

Discussion in 'General Discussion' started by Mladen, Feb 4, 2016.

  1. Mladen

    Mladen Registered

    Joined:
    Feb 4, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Republic of Srpska
    cPanel Access Level:
    Root Administrator
    On my email arrives and up to 5 messages per minute with the following content.

    When in Main >> Server Status >> Service Status disable LFD then it's ok.


    How can I solve this problem but it does not have to disable LFD?
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,532
    Likes Received:
    1,965
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please keep in mind that CSF/LFD is a third-party application. You may want to report this issue on their forums:

    ConfigServer Community Forum - Index page

    Also, as far as your server, ensure that Rsyslogd is running:

    Code:
    /scripts/restartsrv_rsyslogd --status
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    postcd likes this.
  3. tui

    tui Well-Known Member

    Joined:
    Jun 15, 2007
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    58
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    Hello, i have the same problem in a new server i just installed few minutes ago... i know the lfd alerts are from lfd that is not a cpanel product, however, the alert is send because there is a problem with rsyslogd, in my case rsyslog is not running but i cannot make it start, it isnt listed in Service Configuration »Service Manager as my other servers,


    Code:
    root@server [~]# /scripts/restartsrv_rsyslogd --status
    (XID r7hugc) The “rsyslog” service is disabled.
    Code:
    root@server [~]# /scripts/restartsrv_rsyslogd        
    (XID aews88) The “rsyslog” service is disabled.
    root@server [~]# service rsyslog start
    Redirecting to /bin/systemctl start  rsyslog.service
    Failed to start rsyslog.service: Unit rsyslog.service failed to load: No such file or directory.
    root@server [~]# service rsyslogd start
    Redirecting to /bin/systemctl start  rsyslogd.service
    Failed to start rsyslogd.service: Unit rsyslogd.service failed to load: No such file or directory.
    root@server [~]# service syslog start
    Redirecting to /bin/systemctl start  syslog.service
    Failed to start syslog.service: Unit syslog.service failed to load: No such file or directory.
    It seems that syslog is not installed on server ... im confused
     
    #3 tui, Mar 18, 2016
    Last edited: Mar 18, 2016
  4. tui

    tui Well-Known Member

    Joined:
    Jun 15, 2007
    Messages:
    83
    Likes Received:
    5
    Trophy Points:
    58
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    I manually installed rsyslog it wasn't installed, but is strange, i have 22 servers and i never needed install it manually, its strange...
     
  5. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,532
    Likes Received:
    1,965
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    I am happy to see you were able to address the issue. It's possible this server utilized the "syslogd" package instead of "rsyslogd". You can browse to "WHM >> Service Configuration >> Service Manager" to see if you see multiple services installed (one for syslogd and one for rsyslogd). Otherwise, it's difficult to pinpoint a specific reason why rsyslog was missing from your system.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. fingerprn

    fingerprn Active Member

    Joined:
    Feb 19, 2007
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    151
    I had the same problem and I confirmed that Rsyslogd was running. Looked all over the web for an answer the best I could find was:

    Open etc/csf/csf.conf

    Set SYSLOG_CHECK to 0.

    Restart LFD/CSF

    Not an ideal solution, but it stops the warnings. Obviously, don't use this if Rsyslogd isn't actually running. This seems to be a common problem, so I hope someone will actually figure it out.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice