The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error: File size exceeds the 2mb limit (Webmail Roundcube)

Discussion in 'E-mail Discussions' started by Supriya Aher, Oct 2, 2012.

  1. Supriya Aher

    Supriya Aher Member

    Joined:
    Jan 18, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I get this Error: File size exceeds the 2mb limit , when trying to attach an attachment to the mail in roundcube.
    Files less than 2Mb get attached easily.

    NOTE: more than 2mb files get attached in Horde & Squirrelmail easily.

    Any workaround here? Please help.

    FYI:
    1. message_size_limit has been increased in server main php.ini as well as roundcube php.ini
    2. Tried to increase it in /etc/exim.conf even but in vain.
     
  2. pwhjenny

    pwhjenny Well-Known Member

    Joined:
    Aug 31, 2012
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    You've to change the php parameters "upload_max_filesize" & "post_max_size" either in your global php.ini
     
  3. Supriya Aher

    Supriya Aher Member

    Joined:
    Jan 18, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    yes, tried that even, sorry but no luck :(
    any other setting?
     
  4. arunsv84

    arunsv84 Well-Known Member

    Joined:
    Oct 20, 2008
    Messages:
    373
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    127.0.0.1
    cPanel Access Level:
    Root Administrator
    Hi,

    Is there a limit in .htaccess ?
     
  5. Supriya Aher

    Supriya Aher Member

    Joined:
    Jan 18, 2012
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes its already 50mb ..but does not work :(
    Is it roundcube bug or something?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Could you confirm if there are any third-party email applications such as "ASSP" or "Mail Scanner" installed on this server? If there are no third-party email applications installed, please let us know which version of Roundcube is installed on your server:

    Code:
    # cat /var/cpanel/roundcube/version
    Thank you.
     
  7. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you also check in /usr/local/cpanel/3rdparty/etc/php.ini.dist file what is listed for those directives for PHP? If it isn't the size you need, please increase those values in that specific file, then restart cPanel:

    Code:
    /etc/init.d/cpanel restart
    After that, check that /usr/local/cpanel/3rdparty/etc/php.ini shows the new values. If it does, check Roundcube again to see if it is working for the large file sizes you are mentioning for attachments.
     
Loading...

Share This Page